HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

No way to setup Windows Server on ML150 Gen9

 

No way to setup Windows Server on ML150 Gen9

Hi folks,

 

my first encounter with a brand new ML150 Gen9 was quite disappointing. Turned it on and pressed F10 for "Intelligent Provisioning" - it's slooooow. I clicked on "Firmware Update" and it suggested to update some of the components. But in the list of outdated components there was no difference between "installed" and "new" firmware version. When you hit "Install" it does something, but you don't get informed, what, whether it was successfull or not. I then tried "Intelligent Provisioning Preferences". After typing in static IP addresses for Network and ILO a small message box appears that says "Initializing Networking". This box never disappeares, the system is hanging completely, I can only switch it off (DHCP may work, did not try).

 

But worse is, that I failed setting up Windows Server. When accessing the server remote via ILO and trying to use an ISO as "Virtual Media" it does not work. A dialog opens and asks me to point to the location of the ISO. But when you select it, the system does not accept it, it continues to ask me to connect to a virtual media. I closed ILO and went back to the console and tried to boot from usb flash drive, it does work neither. Since the server has no DVD drive I used Microsoft Windows USB/DVD utility to create a bootable 64GB USB flash drive from Microsoft evaluation version of Server 2012. The drive works as boot media on a client system, but not on server. The server indeed recognizes the USB drive and offers it as boot drive, but when hitting enter boot menu screen returns immediately to previous screen and nothing happens. I tried different USB 3.0 and 2.0 ports without success. The server came with a DVD labeled as recovery media (it's a CTO system with ROK license for server 2012 R2) . I transfered this DVD onto flash drive and was able to boot a client computer, but it does not work on server neither.

 

The next option is to use "Intelligent Provisioning" and specify a source for setup files. You can choose between FTP, USB and so on. When you select USB, a file open dialog appears and shows the content of linux mount folder. When I then insert my USB drive, indeed a new folder appears on the screen. If the USB drive contains an ISO, I can click on it, but nothing happens, no way to start OS setup. And if USB drive is bootable instead of containing ISO file again there is no way to start any action.

 

I would greatly appreciate if someone could share his or her ideas to any of these problems. Thanks for reading!

 

Regards,
Stefano

2 REPLIES

Re: No way to setup Windows Server on ML150 Gen9

TL;DR, isn't it? :-)

waaronb
Respected Contributor

Re: No way to setup Windows Server on ML150 Gen9

I've installed Windows Server 2012 R2 on a DL380 Gen9 using ILO virtual DVD drive without any problems.

 

When you use the ILO remote console and pick the "Virtual Drives" option, are you using the "Image File - CD-ROM/DVD" option and using a valid, error-free bootable ISO?

 

I know all of those things should be obvious but I've seen some people have problems only to find out their ISO was corrupt and wouldn't boot on any system at all. :)

 

Also, if you use the built-in intelligent provisioning and do a firmware update, any updates it knows about are probably already installed on the system.  You would need to supply a new support pack or have newer firmware installs available via USB or whatever for it to really be able to do anything, usually.  If you have new firmware on a USB it *should* see it, but it sounds like maybe you just downloaded some firmware installs and put that right onto the USB device?  Download the firmware with the "for USB key media" or whatever and follow along with that, or you can try downloading the Linux version of a firmware update which has the same file type inside.

 

Try getting the latest support pack and booting off that ISO (which will also test your ability to boot from a virtual ISO besides your Windows install) and see how that goes.

 

I can't be much more help since, as I mentioned, I don't really use the IP feature that much... I generally boot off the Windows ISO and install directly, and any firmware updates I do are using the Windows "online" versions.