ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Only one CPU on Proliant 1600 /500 and W2003 enterprise

SOLVED
Go to solution

Only one CPU on Proliant 1600 /500 and W2003 enterprise

Hello, i have this old server, do you know if is possible to make the operating system windows server 2003 enterprise sp1 to recognise both the CPU's ? I installed also rompaq from smartstart CD 5.10 but without results.
12 REPLIES
Igor Karasik
Honored Contributor

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

Marco,
We have Proliant 1600 2*500 CPU and 1 Gb RAM and we see both CPU's in windows 2003
Check that OS settings in System configuration utility is "windows 2000" OS
http://support.microsoft.com/kb/252326/en-us
Do you have 11/08/2000 BIOS?
Do you see two CPU's during POST proccess?

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

Yes, during boot i can see both CPU's
Yes, i have that BIOS

I'll try with the solutions suggested by the Microsoft website, thanks a lot! I'll let you know.

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

I think i discovered the problem: on device manager, under the group computer, i see "Standard PC". This is wrong because i should see "multiprocessor HAL" or something like that.

Do you know how to change it?
Igor Karasik
Honored Contributor

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

http://support.microsoft.com/kb/234558

Did you check you have "windows 2000" defined as OS in System configuration utility?

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

Yes, i checked that link already but i have windows 2003, not 2000 and the solution reported does not apply, i have no choice at the "upgrade drivers" menu.

I'm sure on the system configuration utility there is already set "WINDOWS 2000"
Igor Karasik
Honored Contributor

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

Marco,
it work in windows 2003 too.
Select Update drivers, select not connect to windows update, in next window select "Install from a list or specific location (Advanced)" (second choise);
in next window select "Don't search. I will choise the driver to install" and click Next.
You will see "MPS multiprocessor PC" choise.

Good luck !

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

I really appreciate your effort but unfortunately this is the exact path i followed, and on that menu i only have "standard PC" option available to choose.

Probably it's because when installing the OS the first time, the option was set as "other OS" on the configuration page.

So i guess the only solution is reinstalling the OS ?
Igor Karasik
Honored Contributor

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

Marco,

>>So i guess the only solution is
reinstalling the OS ?

Unfortunately I think you are right.
http://support.microsoft.com/?id=309283
"2. If an incorrect HAL is forced during Setup or by using a System Preparation Image (Sysprep), you can see the correct list of HALs only if you perform a new installation of Windows XP or Windows Server 2003. You cannot change to a HAL other than what is listed in Device Manager"

P.S.
Not for my previous answers, but in general:
I see in your profile:
"I have assigned points to 1 of 34 responses to my questions "
Read http://forums1.itrc.hp.com/service/forums/helptips.do?#28

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

Ok so wich one of those should i choose when installing?

-ACPI Multiprocessor PC
-Advanced Configuration and Power Interface (ACPI) PC
-MPS Multiprocessor PC
-Compaq SystemPro Multiprocessor or 100% Compatible

For the points, you are right, sometimes i forget to assign them (and other times i do not get an answer at all:-) )
In this case i'll do
Igor Karasik
Honored Contributor
Solution

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

You don't need to choose, during windows 2003 installation "MPS multiprocessor PC" HAL will be installed automatically.
Proliant 1600 is Non-ACPI.

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

And why that option was not chosen automatically the first time i installed the OS ? because the "windows2000" option was not set on system configuration?

Anyhow, i manually specified MPS multiprocessor and in 30 minutes it completed the installation perfectly, now i can see 2 CPU's!!!!

THanks again for your precipous help

Re: Only one CPU on Proliant 1600 /500 and W2003 enterprise

problem solved