ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Only one hard disk is being detected when there are clearly two

yxs8495
Occasional Contributor

Only one hard disk is being detected when there are clearly two

I have a HP Proliant DL380 G7 2X2.93GHz 64GB RAM and have tried both ubuntu 16.10 and centos 7. 

According to the specs the lights indicate that the hard drives are ok, but all operating system checks e.g fdisk, dir /dev/sd* lsblk do not show two disks of roughly 450GB.

The specs clearly say 2x 450GB 6G SAS HDD. There are smaller partitions, but only one disk of that size.

Can't see how to use the ROM Based Setup Utility to resolve this.

Please advise.

-john 

P.S. Result of lsblk with ubuntu 16.10

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sdb 8:16 1 29.2G 0 disk
└─sdb1 8:17 1 29.2G 0 part /cdrom
sr0 11:0 1 1024M 0 rom
loop0 7:0 0 1.4G 1 loop /rofs
sda 8:0 0 419.2G 0 disk
├─sda2 8:2 0 418.2G 0 part
│ ├─cl-home 252:1 0 336.7G 0 lvm
│ ├─cl-root 252:2 0 50G 0 lvm /media/ubuntu/2995a8e4-cb56-474b-a6a8-cdbda4a4acf3
│ └─cl-swap 252:0 0 31.5G 0 lvm
└─sda1 8:1 0 1G 0 part /media/ubuntu/76f97246-306e-4e56-9bc0-fcbc5d6ca22c

1 REPLY
Jimmy Vance
HPE Pro

Re: Only one hard disk is being detected when there are clearly two

How do you have the drives configured in the Smart Array controller? If they are setup as RAID 1 you will only see one logical drive as shown in your message.  If you want each drive to be a single disk you will need to create two RAID 0 arrays each with one drive in the array




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!