ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

P212 Raid Controller issue

haydennz
Occasional Visitor

P212 Raid Controller issue

I have a HP ML110 G6 with a P212 and I have an issue now booting in to Windows 2008 R2.

 

There was a power failure and a hard drive died. I removed the hard drive, but Windows reboots on the single drive (raid 1) and I get a blue screen, 'unable to mount boot device'.

 

This suggests corruption. However, when doing a repair through Windows, when it asks for the drivers and I select the P212 driver, I get installation fails. So I cannot load the raid drivers to fix the issue.

 

When rebooting, I have to pull out the power as the I 0 logical drives. When I reboot ocne the power has been plugged back in, I can see 1 local drive.

 

Any ideas? Firmware is latest.

3 REPLIES
Ali
HPE Pro

Re: P212 Raid Controller issue

Hi,

 

Looks like Boot partition corruption.

 

I would suggest to replace the failed drive and let smart array controller rebuild the drive. If you have different partitions for OS and Data within the logical drive and then you may reinstall the OS without deleting the existing partitions instead of Repair option.

 

there are different ways to access the windows partitions to backup the info (example: Linux Live CD) if that is really imp for you.

 

Hope this helps,

 

How to Say Thanks... Click on STAR Kudos

 

Cheers,

Aftab

 

 

 

I work for HPE
Looking for a quick resolution to a technical issue for your HPE products? HPE Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
haydennz
Occasional Visitor

Re: P212 Raid Controller issue

Finally got the drive to load. Windows setup is detecting the drive as raw. Is there anything I can do from here?

Re: P212 Raid Controller issue

 

 

If the hard drive is detected separately by the operating system, then it is not part of the same logical drive as that of the operating system!

 

Please verify the hard drive configuration. To do so, restart the server, during POST, while the Smart Array Controller is initialized, press F8 key to launch the Option ROM Configuration for Array (ORCA) and check to which array the hard drive has been configured. Make it part of Smart Array P212 controller and check if the issue is resolved. If the operating system is in the logical drive, of Smart Array P212 controller, then make it part of the RAID 1 and check if the hard drives start rebuilding after adding it to its array.

 

Yet another possibility is that the hard drive may be inserted not in the bays that the Smart Array P212 controller is connected, but to the Integrated 6 ports SATA controller. If that is the case, then connect it to a bay controlled by Smart Array P212 controller.

 

Regards,

 

Vijayasarathy

I work for HPE
Views expressed herein are my personal opinion and is not the views of HPE
To say thanks click the white "thumbs up" icon below!!!