ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

P410i - can't manage spares

P410i - can't manage spares

I've seen a number of folks posting this problem, but have yet to discover an answer...

 

ML350g6, with a P410i, 6 (then 7) SAS drives installed in an 8 drive cage.

 

Have a RAID1 array for the system volume and a RAID10 array for the data volume.   One drive failed in the RAID10 array, and the volume went down completely.   Not very effective RAID, in my opinion.   Oh well, stuff happens.

 

Client ordered two replacements, with the idea that we'd replace the failed drive and add a hot spare.  

 

Installed the replacement for the failed drive and the array rebuilt itself.   Had to restore the volume from backup (great fault tolerance) and they were running fine afterward.

 

Installed the spare, and went into the ACU but there is nothing in the menus to "Manage Spares".  What do I need to do to create a hot spare?   I made sure the ACU was the latest available.   I noticed that the firmware isn't completely current, but the updates from then to now all state not to bother upgrading unless the upgrades list my issue.   Since none of the last 2 or 3 firmware updates mention that they suddenly enable "Manage Spares", I have been reluctant to install the FW update.   It would be just my luck that the update would trash the entire server...

 

I have since configured the spare drive as a RAID0 array (all by oteself) and provided it to the OS as a place to write Shadowcopies.  However, the client wants to add a hot spare, and has another drive on order.

 

HP Chat won't even answer unless the server is under warranty, so I am hoping someone here can enlighten me.  What do I need to do to create a hot spare with this controller?

 

Thanks...

 

 

P.S. This thread has been moved from Storage>General to ProLiant Servers (ML,DL,SL). -HP Forum Moderator

10 REPLIES
PGTRI
Honored Contributor

Re: P410i - can't manage spares

hi,

 

Do you have a BBWC/FBWC module?

 

Thanks

 

regards,

How to Say Thank You? Just click the KUDOS!
waaronb
Respected Contributor

Re: P410i - can't manage spares

This is the second post recently where someone mentioned removing a drive or having a drive fail where it took down the array. That's pretty unusual, and it makes me wonder if there was another drive that had also failed already, or if something else was going on.

I've never had a drive failure or problem removing a drive from a properly operating array, unless it was my own mistake like removing a 2nd drive before the first one I replaced had finished rebuilding. :)

Look at the ADU and it shows info like if a drive was hot removed previously, and it may give you an idea like if someone onsite pulled a drive and then popped it back in for some reason. Maybe they pulled the wrong drive at first or something. Sometimes that happens when dealing with remote clients who might try to fix an issue on their own.

As suggested by the other commenter, make sure there's a cache installed with a working battery or supercap. I think that might be a requirement for hot spares but I'm not sure. At any rate, it's a good idea.

You probably know this, but if you've created an array on that single drive, it won't be available for use as a spare.

I don't know what version of SSA you're using, or if you're still using the old ACU, but I just popped an extra drive into one of my systems to remind myself how to add a spare.

You click on the arrays, select the array you want to manage the spares on, and there's a button "Manage Spare Drives" right there. If you have any unassigned drives you can select it and add it as a spare.

If you want it to be a global spare, no problem, select any other array where you want that same drive to be a spare and you should be able to do that.

I just added a 146GB drive as a spare on both a RAID 5 with 72GB drives, and a RAID 5 with 146GB drives.

And just to point out the obvious, make sure the drive is as big or bigger than any drive it's meant to act as a spare for.

Re: P410i - can't manage spares

Yes, a 512MB BBWC.

 

 

Re: P410i - can't manage spares

I have created a RAID0 on the spare now for the client's use for storing Utilty stuff and to store shadowcopies.

 

However, before doing that, I still could not find "Manage Spare Drives" anywhere.  The unallocated drive was there, waiting for me to do something with it, but there was simply no place for me to configure it as a hot spare.   Spent a lot of time looking, on the server and on the web.

 

There is a BBWC 512MB write cache, and the ACU shows it as fully charged and most of the cache space is available.

 

Client plans to get another spare drive, and I'd like to configure it as a hot spare for him, but am not feeling all warm and fuzzy about my ability to do that.  

 

I am using the latest ACU (in Windows) and found a posting somewhere that suggested that the only place to actually configure hot spares is by booting to the SmartStart CD and using the ACU in there.  Seems kind of dumb, being able to swap out drives with the server up, but having to take it down to configure them! 

 

Documentation I've found and other advice received would suggest that this should be manageable both from the ACU in Windows OR in the ACU in the SmartStart.   I don't want to visit the client and boot to the latest CD and find I still can't manage spare drives...

 

ADU report is huge - gonna have to spend another day learning how to read it

 

 

Appreciate your input.  I figure I will need to actually go onsite, slip in the spare and hope that the ACU sees it and offers me the ability to Manage Spares.  Don't see whay it would - it hasn't up to now.

 

HP sure makes good stuff, but heaven help you if you need them afterward.   Warranty service has been outstanding (although I haven't needed it much), but if you have no warranty plan, forget them...

 

Thanks.

PGTRI
Honored Contributor

Re: P410i - can't manage spares

hi,

 

Can you please attach the ACU report here?

 

Thanks

 

regards,

How to Say Thank You? Just click the KUDOS!

Re: P410i - can't manage spares

Sorry, this darned forum isn't sending me notifications. I will get that for you.

Thanks!

Re: P410i - can't manage spares

Here's that ACU report.

 

Thanks for looking at it...

PGTRI
Honored Contributor

Re: P410i - can't manage spares

hi,

 

It seems that drives 6 and 7 are non hp labeled. Can you please check that and if yes, remove these drives and check, if you can manage a spare. Please try only with hp labeled drives.

 

Thanks

 

regards,

How to Say Thank You? Just click the KUDOS!

Re: P410i - can't manage spares

My dealer told me that HP labelled drives of this type are no longer available, so I had to purchase 3rd-party drives to replace the failed ones.

 

If that's the problem, then so be it.

 

 

Another way HP disappoints, I guess...

Wish I could find this somewhere in their documentation:   be nice to be able to show the client...

 

Thanks for your assistance.

 

 

 

waaronb
Respected Contributor

Re: P410i - can't manage spares

I have a couple servers with non HP drives and except for the Gen8 models, I haven't had any issues. I can still make array changes and do whatever you can with an HP drive.

Lately, the vendor I use has HP drives at or even below some of the 3rd part drives like Axiom, so I do try to stick with HP drives when possible.

Your vendor might not be able to find an *exact* match, but trust me, there are compatible HP drives out there, they just might be something like using dual-port drives even if your system only uses a single port.

The HP qiuckspecs pages for your product are typically kept up to date, so if some drive option is no longer available, HP updates those with a compatible spare part #.