ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

P420 without Flash

 
Occasional Visitor

P420 without Flash

I've just recived my DL380e Gen8 (My first server).

If I try to change the configuration (using the ssacli tool) I get the following reslut:

# ssacli controller all modify hbamode=on forced

Smart Array P420 in Slot 1 (sn: PDSXK0BRH5Q1O7)

CACHE STATUS PROBLEM DETECTED: The controller is disabled because the cache
module is not attached. Please re-attach the
cache module to re-enable the controller.

 

How do I get it to work WITHOUT a cache?

4 REPLIES 4
HPE Pro

Re: P420 without Flash


1. I understand that you are looking to set the controller to HBA mode.

# ssacli controller all modify hbamode=on forced

Please check of you have disabled (AHCI mode) the onboard B120i controller from RBSU. - To ensure of the error is not for the onboard controller.

2. What happens if you try to re-configure RAID volume (1 or 0 but no RAID 5 since no cache is present) instead of changing to HBA mode? Do you see any issue?

3. Also, did you try with a different version of ssacli? Maybe you can try with an older version which is called hpacucli?

I am an HPE employee
Accept or Kudo
Occasional Visitor

Re: P420 without Flash

Yes, I want to enable HBA mode (To run zfs). I haven't checked, the RBSU yet, will do asap. I can't set a RAID mode either. Tried with the ssacli tool as well via Intelligent Provisioning (after POST). The latter doesn't even offer any actions but only shows the error.
HPE Pro

Re: P420 without Flash

Greetings!

By default, it should be RAID mode for the P420 controller. Even if the cache is not installed on the P420 controller, it should allow non-parity RAID creation Example: RAID 0 or RAID 1 

Please try booting from offline SSA and check. Before that please check if the B120i is disabled in BIOS.

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_50309f0541d14018bb674c59b8 

If the issue persists,  try doing a BIOS defaults and then disable B120i and check. If nogo then we may have to look at the firmware and other details from the logs to further isolate. 

Please log a support ticket to  get this investigated: https://pg-receiver-pro.glb.itcs.hpe.com/WclWeb/WclEntry.aspx

 

I am an HPE employee
Accept or Kudo
Honored Contributor

Re: P420 without Flash


@anon3847 wrote:

I've just recived my DL380e Gen8 (My first server).

If I try to change the configuration (using the ssacli tool) I get the following reslut:

# ssacli controller all modify hbamode=on forced

Smart Array P420 in Slot 1 (sn: PDSXK0BRH5Q1O7)

CACHE STATUS PROBLEM DETECTED: The controller is disabled because the cache
module is not attached. Please re-attach the
cache module to re-enable the controller.

 

How do I get it to work WITHOUT a cache?


Try specifying the controller 'slot=' instead of using 'all'

No support by private messages. Please ask the forum!