ProLiant Servers (ML,DL,SL)

P420i smart array controller has died

 
SOLVED
Go to solution
ZZZXXXRRR
Visitor

P420i smart array controller has died

HP DL380p Gen8 E5-2640v2 US Svr/S-Buy    

Product ID:  653200-B21

Hey there I've got the dreaded but not uncommon:

Slot 0 HP Smart Array P420i Controller nitializing…

1783-Slot 0 Drive Array Controller Failure!

[Self-test failure (cmd=0h, err=00h, lockup=0DEAD:DEADh)]

 

I have reseated the cache card already, checked the SAS cables.

 

I ran the SPP 8.1 iso from the java based iLO4 remote console and updated everything. It's still throwing the same error. (all firmware should be up to date) **NOTE it DID NOT work using the HTML5 version of the iLO4 remote console. It got to the screen with clouds but never moved forward from there for upwards 20 min until I gave up and restarted it. Use the JAVA based remote console.

 

Currently disabled the device and tried going to the intel embedded sata controller to try and run a samsung sata SSD I just put in there in hopes of getting something.

 

This machine is playing a role in a manufacturing tool. If we could fix it quick, that would be one path but we really just need ANY windows PC in this slot. What can i do to boot windows server 2012 in ANY possible configuration even with data loss?

I tried installing a PCIE M.2 board with an NVME drive on it  --> didn't work can't boot from NVME. It's visible to the windows installer though.

 

I tried taking a normal samsung 2.5" SSD and attaching the rails from an old hard drive and put it in the backplane. --> Server can't see it.

 

I ordered a used P420 PCIE card hoping to just unplug the existing SAS cables from the motherboard and plug them into the PCIE card when it arrives.

 

2 REPLIES 2
ZZZXXXRRR
Visitor
Solution

Re: P420i smart array controller has died

So I tried everything, I ended up installing an instance of windows to go on a NAND Samsung SSD I had lying around.

I used RUFUS and set the settings for "windows to go" as well as "partition scheme MBR/BIOS", I used a [Windows Server 2012R2].iso I got from microsoft as an evaluation version.

I also got a regular windows 10 iso BUT NOT through the Microsoft official media creator tool. That apparently doesn't work, to get an iso I had to change my user agent on chrome to appear as Safari, otherwise Microsoft tries to force you to use their media creation tool. I didn't end up using this, I'm only writing about it because whoever sees this in the future might need to know the media creation tool ISO's don't seem to work with "windows to go".

I connected my SSD to the DL380P via USB using a SATA-USB adapter with an external power supply for the drive.

The server booted up just fine, and I was able to get our production software installed to help us limp for the night. It would shut down after some time...iLO4 reports it as "power removed". I don't know but it was enough to last one night until the ------ package showed up this morning.

The P420 (PCIE version of the raid controller) arrived (it came with the BBWC and a new battery).

I installed that in the PCIE "riser" and took ONE of the SAS cables and plugged it in. We only use 4 hard drives and because of the "L" shaped connector and plug arrangements I was only able to fit one plug into the PCIE card.

I ordered 2 new cables with straight-straight SAS connectors. HPE part 662897-B21 I could have gotten away with 1 but the "L" connector is a tiny bit shorter than I'm comfortable with (it's applying a little bit of stress to the P420 controller port). I might zip tie it to the side of the case with a plastic stick on zip tie anchor to support the weight of the wire better.

The system booted up, found all the drives and started as if none of this nightmare had ever happened! It all worked out.

I should probably update the firmware on this controller using the SPP81.4.ISO too... the label on the package says it's from 2015.

SanjeevGoyal
HPE Pro

Re: P420i smart array controller has died

Hello,

 

You already ordered SA P420, you have to wait for this.

Please let me know if the issue still persists after replacement.

 


I am a HPE Employee

Accept or Kudo