ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Performance issues with RemoteFX, what's wrong?

Fantinati
Occasional Contributor

Performance issues with RemoteFX, what's wrong?

Performance issues with RemoteFX, what's wrong?

 

Our hardware configuration

Server: HP - ProLiant ML350p gen8 (Tower server)

Processor: Single processor - Intel Xeon E5-2620 Six-Core 2GHz (SLAT enabled)

GPU: NVIDIA GRID K1

RAM: 64 MB – DDR3-1333 – 30% free for host server

 

Our software configuration

Server BIOS:  HP P72 (20/12/2013)

Windows server 2012R2 – Hyper-V – Remote desktop virtualization host

NVIDIA GRID Series drivers v.333.11 or NVIDIA GRID VGPU drivers v.332.83 (both tested)

System center 2012 virtual machine manager SP1

 

RemoteFX Configuration server

Embedded Matrox G200 card disabled from RBSU (BIOS)

NVIDIA driver installed correctly, device manager show 4 items “NVIDIA GRID K1”

Hyper-V console show four “NVIDIA GRID K1 GPU”, all enabled.

 

RemoteFX Configuration client (VM)

Windows 8.1 cleaned installation - fully updated at 20/05/2014

Installed K-Lite Codec Pack 10.5.0 Mega version (does not seem to make any difference)

Remote FX 3D graphics card added to VM client machine.

Virtual processors: 6

Memory: 8GB – static and set to High priority

LAN: dedicated 1Gbps

Device manager show correctly RemoteFX VDDM driver.

tested many configurations in Gpedit.msc

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

 

 

How to run tests

The tests where repeated on several client computers from the LAN (1Gbps), WAN (100Mbps) through RDP Gateway, or directly connected to the VPN.

RDP client report Excellent or good quality connection and UDP enabled

Playback of 720p video with Windows Media Player

Internet Explorer Test Drive: http://ie.microsoft.com/testdrive/

http://ie.microsoft.com/testdrive/performance/fishbowl/

http://ie.microsoft.com/testdrive/Performance/Popcorn/

 

Results

In all test modes occurs a large amount of lost frames

K1 performance is poor and less than Matrox G200 (embedded card).

 

Performance counter

K1 GPU usage counter show that k1 works

Frames Skipped/second – Insufficient Client Resources = 0

Frames Skipped/second – Insufficient Network Resources = 0

Frames Skipped/second – Insufficient Server Resources = High values 30/40 fps

 

Any suggestions would be appreciated

 

Cristiano Fantinati

IT Administrator - IPSIA F.lli Taddia

 

 

3 REPLIES
Jiří Janata
Occasional Visitor

Re: Performance issues with RemoteFX, what's wrong?

Hi,

 

I have same issue - there is no problem with your server - if you look at your processor usage (in task manager), there is process, which use only one core for 100%. And that's the problem - this process allocating resources and is not fast enough. Maybe in next/next-next version will Microsoft rewrite this program to be multithreaded. Until this is RemoteFX only crap (in comparsion with vSGA from VMware, etc.)

Fantinati
Occasional Contributor

Re: Performance issues with RemoteFX, what's wrong?

In our case, does not seem to be the same problem
During graphical test in the VM, the CPU usage is low in all cores.
The graphic performance are insufficient but no other suspect signal is present in the VM.
Cutha
Occasional Visitor

Re: Performance issues with RemoteFX, what's wrong?

Hi,

I have a different setup but the same issue. Did you ever figure out what the problem was? I have been searching everywhere for answers...

Thanks,
Seamus