ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Powershell - HPOACmdlets - Issues with NIC Server Info

michael_foley
Occasional Visitor

Powershell - HPOACmdlets - Issues with NIC Server Info

Hi Everyone

Hopefully this is in the right spot.

I've just come across the HPOACmdlets along with the HPILOCmdlets, which we are hoping to use to generate some information as part of our server provisioning process, mostly network interface configuration for our network guys.

I've managed to get the NIC information using  Get-HPOAServerInfo and the ServerBlade.FLBAdapter and Server.Blade.Mezzanine Properties of the results,

$ServerInfo.ServerBlade.FLBAdapter

EthernetLOM      : {@{Value=1-a   AA:BB:CC:DD:EE:FF; EthernetLOMNumber=1}}
EthernetNIC1LOM1 : 2-a           AA:BB:CC:DD:EE:EE
FLBAdapterNumber : 1

$ServerInfo.ServerBlade.Mezzanine | Format-List

EthernetMZ      : {@{Value=2-a   AA:BB:CC:DD:EE:DD; EthernetMZNumber=2}}
MezzanineNumber : 2

 

after a bit of messing about with the return I managed to get the interfaces into a reasonbly nice object:

Adapter      : FLB1
Name         : EthernetLOM
Type         : Ethernet
PhysicalAddr : AA:BB:CC:DD:EE:FF
Mapping      : 1-a

Adapter      : FLB1
Name         : EthernetNIC1LOM1
Type         : Ethernet
PhysicalAddr : AA:BB:CC:DD:EE:EE
Mapping      : 2-a

Adapter      : MEZ2
Name         : EthernetMZ
Type         : Ethernet
PhysicalAddr : AA:BB:CC:DD:EE:DD
Mapping      : 2-a

 

But I don't seem to getting all of the adapters returned for a BL460c Gen9 Half Height server Mez Card.

From the OA Device Bay Information Page I can see that I have more adapters than what I have managed to populate via the script:

FLB Adapter 1: HP FlexFabric 20Gb 2-port 650FLB Adapter

Ethernet LOM1:1-a AA:BB:CC:DD:EE:FF

Ethernet LOM1:2-a AA:BB:CC:DD:EE:EE

 

2 HP FlexFabric 20Gb 2-port 650M Adapter

Ethernet MZ2:1-a AA:BB:CC:DD:EE:CC
Ethernet MZ2:2-a  AA:BB:CC:DD:EE:DD
 

 I've tested this with a Full Height BL660c Gen8 without Mez cards and all 4 Onboard NICS were returned.

On top of that only one of the 2 FCoE WWN's per interface card are returned as well.

So it doesn't appear to have found MZ2:1-a but MZ2:2-a was found without a problem. Has anyone seen issues with this before?

 

Version details:

Get-HPOAModuleVersion

Name               : HPOACmdlets
Path               : C:\Program Files\Hewlett-Packard\PowerShell\Modules\HPOACmdlets\HPOACmdlets.dll
Description        : Cmdlets to interface with HP OA
GUID               : 38862839-fd60-44a2-935f-adea6170d879
Version            : 1.1.0.1
UICultureName      : en-US
UICultureVersion   : 1.1.0.1
AvailableUICulture : {en-US, zh-CN, ja-JP}

 

 

1 REPLY
GokulKS
Valued Contributor

Re: Powershell - HPOACmdlets - Issues with NIC Server Info

Hi,

The HPOACmdlets version you are using is not the latest and new version 1.1.0.3 has fixes for Get-HPOAServerInfo return data.

Please download the latest version on the HPE website : 1.1.0.3(24 Mar 2015)

Thanks,

Gokul

HPE PowerShell Team

 

Don't forget to give Kudos if the problem got resolved or like suggestion.