ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Powershell Set-HPiLONetworkSetting returns "Error: Line #5: syntax error near "ILO_NIC_AUTO_DELAY""

 
MarcVDH
Occasional Contributor

Powershell Set-HPiLONetworkSetting returns "Error: Line #5: syntax error near "ILO_NIC_AUTO_DELAY""

Hello,

When trying to do simple tasks like setting up the ILO DNSname or the ILO primary DNS server, the set-HPiLONetworkSetting command always returns Error: Line #5: syntax error near "ILO_NIC_AUTO_DELAY".

I am using the latest ILO cmdlets v1.4.0.1
The commands that I am launching are these :
Set-HPiLONetworkSetting -Server $ILOip -Username xxxxx-Password xxxxx -DisableCertificateAuthentication -DNSName $ILOname
Set-HPiLONetworkSetting -Server $ILOip -Username xxxxx-Password xxxxx -DisableCertificateAuthentication -PrimDNSServer $DNSip

 

Doing a  Get-HPiLONetworkSetting gives me this :
IP                               : xx.xx.xx.xx
HOSTNAME                         :
STATUS_TYPE                      : OK
STATUS_MESSAGE                   : OK
DHCPV6_DNS_SERVER                : Y
DHCPV6_DOMAIN_NAME               : N
DHCPV6_RAPID_COMMIT              : N
DHCPV6_SNTP_SETTINGS             : Y
DHCPV6_STATEFUL_ENABLE           : Y
DHCPV6_STATELESS_ENABLE          : Y
DHCP_DNS_SERVER                  : N
DHCP_DOMAIN_NAME                 : N
DHCP_ENABLE                      : N
DHCP_GATEWAY                     : N
DHCP_SNTP_SETTINGS               : N
DHCP_STATIC_ROUTE                : N
DHCP_WINS_SERVER                 : N
DNS_NAME                         : xxxxxxxxx
DOMAIN_NAME                      :
ENABLE_NIC                       : Y
FULL_DUPLEX                      : Automatic
GATEWAY_IP_ADDRESS               : xx.xx.xx.xx
ILO_NIC_AUTO_SELECT              : DISABLED
IPV6_ADDRESS                     : fe80::9eb6:54ff:fe73:9d7e
IPV6_ADDRESS_ADDR_SOURCE         : SLAAC
IPV6_ADDRESS_ADDR_STATUS         : ACTIVE
IPV6_ADDRESS_PREFIXLEN           : 64
IPV6_ADDR_AUTOCFG                : Y
IPV6_DEFAULT_GATEWAY             : ::
IPV6_PREFERRED_PROTOCOL          : Y
IPV6_PRIM_DNS_SERVER             : ::
IPV6_REG_DDNS_SERVER             : Y
IPV6_SEC_DNS_SERVER              : ::
IPV6_STATIC_ROUTE_1_ADDR_STATUS  : INACTIVE
IPV6_STATIC_ROUTE_1_IPV6_DEST    : ::
IPV6_STATIC_ROUTE_1_IPV6_GATEWAY : ::
IPV6_STATIC_ROUTE_1_PREFIXLEN    : 0
IPV6_STATIC_ROUTE_2_ADDR_STATUS  : INACTIVE
IPV6_STATIC_ROUTE_2_IPV6_DEST    : ::
IPV6_STATIC_ROUTE_2_IPV6_GATEWAY : ::
IPV6_STATIC_ROUTE_2_PREFIXLEN    : 0
IPV6_STATIC_ROUTE_3_ADDR_STATUS  : INACTIVE
IPV6_STATIC_ROUTE_3_IPV6_DEST    : ::
IPV6_STATIC_ROUTE_3_IPV6_GATEWAY : ::
IPV6_STATIC_ROUTE_3_PREFIXLEN    : 0
IPV6_TER_DNS_SERVER              : ::
IP_ADDRESS                       : xx.xx.xx.xx
MAC_ADDRESS                      : aa:aa:aa:aa:aa:aa
NIC_SPEED                        : Automatic
PING_GATEWAY                     : Y
PRIM_DNS_SERVER                  : xx.xx.xx.xx
PRIM_WINS_SERVER                 : 0.0.0.0
REG_DDNS_SERVER                  : Y
REG_WINS_SERVER                  : Y
SEC_DNS_SERVER                   : 0.0.0.0
SEC_WINS_SERVER                  : 0.0.0.0
SHARED_NETWORK_PORT              : N
SNP_PORT                         : 1
SNTP_SERVER1                     :
SNTP_SERVER2                     :
SPEED_AUTOSELECT                 : Y
STATIC_ROUTE_1_DEST              : 0.0.0.0
STATIC_ROUTE_1_GATEWAY           : 0.0.0.0
STATIC_ROUTE_1_MASK              : 0.0.0.0
STATIC_ROUTE_2_DEST              : 0.0.0.0
STATIC_ROUTE_2_GATEWAY           : 0.0.0.0
STATIC_ROUTE_2_MASK              : 0.0.0.0
STATIC_ROUTE_3_DEST              : 0.0.0.0
STATIC_ROUTE_3_GATEWAY           : 0.0.0.0
STATIC_ROUTE_3_MASK              : 0.0.0.0
SUBNET_MASK                      : 255.255.255.0
TER_DNS_SERVER                   : 0.0.0.0
TIMEZONE                         : Atlantic/Reykjavik
VLAN_ENABLED                     : N
VLAN_ID                          : 0

No ILO_NIC_AUTO_DELAY parameter can be found.
In the end I tried to flash the ILO firmware, the version I had was 2.0 and it is now 2.5.
If I try again, I can see the ILO_NIC_AUTO_DELAY paramter and the cmdlet to configure the network settings works correctly.

Here is the same command with the new firmware :
IP                               : xx.xx.xx.xx
HOSTNAME                         :
STATUS_TYPE                      : OK
STATUS_MESSAGE                   : OK
DHCPV6_DNS_SERVER                : Y
DHCPV6_DOMAIN_NAME               : N
DHCPV6_RAPID_COMMIT              : N
DHCPV6_SNTP_SETTINGS             : Y
DHCPV6_STATEFUL_ENABLE           : Y
DHCPV6_STATELESS_ENABLE          : Y
DHCP_DNS_SERVER                  : N
DHCP_DOMAIN_NAME                 : N
DHCP_ENABLE                      : N
DHCP_GATEWAY                     : N
DHCP_SNTP_SETTINGS               : N
DHCP_STATIC_ROUTE                : N
DHCP_WINS_SERVER                 : N
DNS_NAME                         : xxxxxxxxxx
DOMAIN_NAME                      :
ENABLE_NIC                       : Y
FULL_DUPLEX                      : Automatic
GATEWAY_IP_ADDRESS               : xx.xx.xx.xx
ILO_NIC_AUTO_DELAY               : 90
ILO_NIC_AUTO_SELECT              : DISABLED
ILO_NIC_AUTO_SNP_SCAN            : 0
ILO_NIC_FAIL_OVER                : DISABLED
ILO_NIC_FAIL_OVER_DELAY          : 300
IPV6_ADDRESS                     : fe80::9eb6:54ff:fe73:9d7e
IPV6_ADDRESS_ADDR_SOURCE         : SLAAC
IPV6_ADDRESS_ADDR_STATUS         : ACTIVE
IPV6_ADDRESS_PREFIXLEN           : 64
IPV6_ADDR_AUTOCFG                : Y
IPV6_DEFAULT_GATEWAY             : ::
IPV6_PREFERRED_PROTOCOL          : Y
IPV6_PRIM_DNS_SERVER             : ::
IPV6_REG_DDNS_SERVER             : Y
IPV6_SEC_DNS_SERVER              : ::
IPV6_STATIC_ROUTE_1_ADDR_STATUS  : INACTIVE
IPV6_STATIC_ROUTE_1_IPV6_DEST    : ::
IPV6_STATIC_ROUTE_1_IPV6_GATEWAY : ::
IPV6_STATIC_ROUTE_1_PREFIXLEN    : 0
IPV6_STATIC_ROUTE_2_ADDR_STATUS  : INACTIVE
IPV6_STATIC_ROUTE_2_IPV6_DEST    : ::
IPV6_STATIC_ROUTE_2_IPV6_GATEWAY : ::
IPV6_STATIC_ROUTE_2_PREFIXLEN    : 0
IPV6_STATIC_ROUTE_3_ADDR_STATUS  : INACTIVE
IPV6_STATIC_ROUTE_3_IPV6_DEST    : ::
IPV6_STATIC_ROUTE_3_IPV6_GATEWAY : ::
IPV6_STATIC_ROUTE_3_PREFIXLEN    : 0
IPV6_TER_DNS_SERVER              : ::
IP_ADDRESS                       : xx.xx.xx.xx
MAC_ADDRESS                      : aa:bb:cc:dd:ee:ff
NIC_SPEED                        : Automatic
PING_GATEWAY                     : Y
PRIM_DNS_SERVER                  : xx.xx.xx.xx
PRIM_WINS_SERVER                 : 0.0.0.0
REG_DDNS_SERVER                  : Y
REG_WINS_SERVER                  : Y
SEC_DNS_SERVER                   : 0.0.0.0
SEC_WINS_SERVER                  : 0.0.0.0
SHARED_NETWORK_PORT              : N
SNP_PORT                         : 1
SNTP_SERVER1                     :
SNTP_SERVER2                     :
SPEED_AUTOSELECT                 : Y
STATIC_ROUTE_1_DEST              : 0.0.0.0
STATIC_ROUTE_1_GATEWAY           : 0.0.0.0
STATIC_ROUTE_1_MASK              : 0.0.0.0
STATIC_ROUTE_2_DEST              : 0.0.0.0
STATIC_ROUTE_2_GATEWAY           : 0.0.0.0
STATIC_ROUTE_2_MASK              : 0.0.0.0
STATIC_ROUTE_3_DEST              : 0.0.0.0
STATIC_ROUTE_3_GATEWAY           : 0.0.0.0
STATIC_ROUTE_3_MASK              : 0.0.0.0
SUBNET_MASK                      : 255.255.255.0
TER_DNS_SERVER                   : 0.0.0.0
TIMEZONE                         : Atlantic/Reykjavik
VLAN_ENABLED                     : N
VLAN_ID                          : 0

Isn't it a bug with the cmdlet as there is no firmware prerequisite to use these cmdlets and they should be compatible with ILO 3 and 4 ?

Regards,

Marc

 

 

1 REPLY
GokulKS
Trusted Contributor

Re: Powershell Set-HPiLONetworkSetting returns "Error: Line #5: syntax error near "ILO_NIC

Hi,

This is a known issue in 1.4.0.1 of iLO cmdlets and it got fixed in 1.4.0.2 hotfix that we provided recently.

Please upgrade to new hotfix version as this was the issue on iLO3 fw version where "ILO_NIC_AUTO_DELAY" was getting added automatically in Set-HPiLONetworkSetting cmdlet which was not supported in iLO3 FW version.

Thanks,

Gokul

HPE PowerShell Team 

Don't forget to give Kudos if the problem got resolved or like suggestion.