ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ProLiant DL360 G3 Health Driver

 
lopsided98
Occasional Contributor

ProLiant DL360 G3 Health Driver

I recently got an old ProLiant DL360 G3 (yes, its very old), and I am trying to figure out how to get the Health driver working on Linux. Mostly, I want to stop the fans from constantly running at full speed.

I am trying to figure out which version of the driver to use and what components are necessary for it to function. Does the latest version of hp-health support this old server, and if not, what version does? Also, are there any kernel modules that are required to use hp-health?

Thanks in advance.

3 REPLIES
Vktor
Frequent Advisor

Re: ProLiant DL360 G3 Health Driver

Maybe this old post help for you something to control fan speed on Linux.

http://community.hpe.com/t5/ProLiant-Servers-ML-DL-SL/DL360-G3-fan-speed-option/td-p/4495577

Necessary components to control fan speed automatically is correctly installed ILO Driver.

Best Regards.

 

 

 

lopsided98
Occasional Contributor

Re: ProLiant DL360 G3 Health Driver

I've seen that thread, but I'm still confused because I can't figure out how to install the necessary drivers. It seems like the newer servers all use IPMI, but the G3 does not. I have not been able to figure out what it does use, and what kernel modules are necessary. Right now I am using hpasm 7.3.0 (because it was the first version before ILO 2 support was added, I assume it must support the original ILO), but I get this error when running hpasmcli: 

hpuid: error while loading shared libraries: error: libhpasmintrfc.so.1: cannot open shared object file: No such file or directory

I assume I am missing a library, but I'm not sure what. 

lopsided98
Occasional Contributor

Re: ProLiant DL360 G3 Health Driver

I have gotten a little farther, and figured out that the kernel modules I need are "cpqasm" and "cpqevt". I am now using version 6.30.0 of hpasm, which was designed to run on kernel version 2.4.9. I was able to make the necessary changes to the cpqasm wrapper to allow it compile against kernel version 4.7.1, but I have now run into the problem that the closed source "casm_common" library was not compiled with the "-fno-common" option, which is now required for kernel modules.

Does anyone know if it is possible to find a version of hpasm that supports a newer kernel (I think the "-fno-common requirement was added in 2.6) and also includes cpqasm and cpqevt? Every version beyond 7.1.0 does not seem to include these kernel modules.

On the other hand, a version "casm_common.o" that is compiled with "-fno-common" might also work.