ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ProLiant DL360p Gen8 ipmi not working

jlausuch
Occasional Visitor

ProLiant DL360p Gen8 ipmi not working

I have an ProLiant DL360p Gen8 server which I want to control with ipmi.

When I try to run something against it it says:

 

ipmitool -I lanplus -H $ip -U $user -P $pass
Error: Unable to establish IPMI v2 / RMCP+ session

 

However, the ip I am using is pingable.

It seems I don't have any authentication algorithm enabled.

 

 

# ipmitool lan print 2
Set in Progress : Set Complete
Auth Type Support :
Auth Type Enable : Callback :
: User :
: Operator :
: Admin :
: OEM :
IP Address Source : Static Address
IP Address : XX.XX.XX.XX
Subnet Mask : 255.255.255.0
MAC Address : 9c:b6:54:8c:b7:cc
SNMP Community String :
BMC ARP Control : ARP Responses Enabled, Gratuitous ARP Disabled
Default Gateway IP : XX.XX.XX.XX
802.1q VLAN ID : Disabled
802.1q VLAN Priority : 0
RMCP+ Cipher Suites : 0,1,2,3
Cipher Suite Priv Max : XuuaXXXXXXXXXXX
: X=Cipher Suite Unused
: c=CALLBACK
: u=USER
: o=OPERATOR
: a=ADMIN
: O=OEM

 

 

The command ipmitool -v lan set 2 auth User PASSWORD does not do anything ...

The firmware is:

        Product Name ProLiant DL360p Gen8

        iLO Firmware Version 2.40 Dec 02 2015

 

What am I missing here?

2 REPLIES
Oscar A. Perez
Honored Contributor

Re: ProLiant DL360p Gen8 ipmi not working

Check that the 'IPMI/DCMI Over LAN access' is enabled in iLO4 ( Administration -> Access Settings ).

Most people want it disabled due to the known IPMI 2.0 RCMP+ Authentication Remote Password Hash Vulnerability (RAKP)

http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c04197764-1

 




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
jlausuch
Occasional Visitor

Re: ProLiant DL360p Gen8 ipmi not working

That was actually enabled. The problem was that the user account I was using in the ipmi command didn't have all the admin rights, so I enabled them in the BIOS settings (by pressing F8 after reboot and chaning everything to "yes") and it worked.

HP ProLiant Gen8 BIOS User Edit