ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ProLiant DL380 G7 - Lost NICs after Driver-Update

 
SOLVED
Go to solution
detlver1
Occasional Advisor

ProLiant DL380 G7 - Lost NICs after Driver-Update

 

Hi,

on a ProLiant DL380 G7 i do a driver update for the Broadcom NICs.

HP NC373F and HP NC382i DP.

The OS is Microsoft Server 2008R2.

The old Driverversion is 7.8.6.0   - cp018873.exe

The new Driver will be 7.8.50.0B - cp021772.exe

 

After i do this all Nics are lost. No network connection is possible.

The devicemanager shows this:

nic.JPG

A fallback to the old driver gets no change. I need to restore the Server completely.

Please fix this issue as soon as posibly.

Thanks.

Greetings

Ralf

16 REPLIES
scharchouf
Trusted Contributor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

to fix this you need to update your server with SPP:

http://h17007.www1.hp.com/us/en/enterprise/servers/products/service_pack/spp/index.aspx#tab=TAB1

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

detlver1
Occasional Advisor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

This bad driver is Part of this SPP.

we deploy the SPP and than we get this error.

after restore we deploy step by step an indentify the NIC driver as the "bad one"

Greetings

Ralf

detlver1
Occasional Advisor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

good morning,

unfortunately the nics are not 10 GgE but1 GbE.

So the driver can't be installed

Greetings

Ralf

scharchouf
Trusted Contributor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

OS is English or German?
you have already uninstalled the old drivers?

it is clear that the concern of pilots, is from a problem of incompatibility
I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

detlver1
Occasional Advisor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

Hi,

the OS is german, always actual patched. I have deinstalled the driver, but the server looks always like the posted image.

after completly restore i deinstalled the "old" driver version. After installing the new ones, the server will be "lost"

On OS Windows Server 2012, all the drivers from the act. SPP working well.

Thanks for your efforts

greetings

Ralf

scharchouf
Trusted Contributor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

If it's Ok Please mark it as a solution and KUDOS
I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

detlver1
Occasional Advisor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

but there is no solution on Server 2008

 

scharchouf
Trusted Contributor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

I am sure that ther's an issue about configuration or something

 

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

gabork
Occasional Visitor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

I installed on 2 Proliant DL380 G7 servers the spp:

HP Service Pack for ProLiant (SPP) Version 2014.02.0

OS: Windows server 2008 R2 Standard, SP1, EN

 

One of them are stopped with blue screen, ...driver problem... After restart in the device manager all network connections ara marked with yellow exclamation mark. I had to delete all adapters and reboot the server.

All adapter came with a new name (number)  Local area connection 4-5-6... and we lost the fix ip config for them.

Now it works after set the correct ip adresses.

 

 

 

 

 

scharchouf
Trusted Contributor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

One servers is Ok and the second server has an issue, that's right?

if you have any screen shoot or log error or everything related to the issue that the server have, please send us in order to investigate

 

thank you

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

detlver1
Occasional Advisor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

Hi,

i configure HP/Compaq ProLiant Servers since abaut 10 years.

A running Server with HP Service Pack for ProLiant Version 2013.09.0B.

After update this SevicePack the Server is unreachable.

After full restore of this machine i only install the cp021772.exe.

Then the Server was "damaged" again.

so, where can a "missconfiguration" been made?

Greetings Ralf

ErikD
Occasional Advisor
Solution

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

@detlver1

 

Do you have any luck with the drivers from cp021772.exe if you try this:

 

1. Extract the drivers from cp021772.exe

2. In Device Manager select to update the driver from the extracted files

 

 

detlver1
Occasional Advisor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

Hi ErikD,

I tried the suggestion and it works.

Configuration is:

4 onboard NICs, one active

1 Fibrechannel-NIC active

this 2 NICs teamed with HP-Network-Configuration-Tool. (Fibre active, onboard standby)

First i patched the active onboard-NIC with "driver-update" from the device-manager and reboot the Server.

This works fine. Than i patched the 3 inactive NICs. No reboot needed.

Now i changed the device-order in the Teaming to onboard active, fibre standby.

i patched the fibre-nic. This was OK too. I changed the device-order in the teaming back to active fibre.

At last i updated the teaming-Software with cp021816.exe to version 10.85.00.0

The server works well. at last i finally reboot the system and....

hooray, it works well.

it seems that the setup of cp021772.exe is the prolem, not the driver himself.

Thank you very much for the support

greetings Ralf

Sorry for my bad english ;)

 

waaronb
Respected Contributor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

There was a recent issue with a firmware update for the 1GB Broadcom multifunction nics that was causing problems.  The firmware update was failing or something, resulting in the NICs not appearing in device manager.

 

If you look on this forum you will find that thread.

 

It's possible that the automated SPP tried running that firmware update on your NIC and resulted in that same issue.

 

I never run automated updates (or try not to), so I don't know for sure if that's your problem, but other people have reported something that sounds similar, and it had nothing to do with the driver.

Chethan23
Occasional Visitor

Re: ProLiant DL380 G7 - Lost NICs after Driver-Update

Hi All,

 

I had updated SPP 2014.09.0 on DL 380 G6 server. But after updating i'm unable to find One of the nic adapter in device manager. Please help me in this.