ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ProLiant Server 380DL

 
Christian Schniering
Occasional Visitor

ProLiant Server 380DL

Hey,

I have a little problem here.
I`m administrating a HP ProLiant Server 380DL right now and i have a problem I cannot solve.
I want to channel-bond my two on-board network adapters to make them one. So, that I have only one IP address given but the double amount of network speed.
How can I do this? I have to commit, I`ve no idea. I already checked the HP Managemnt tool, but i couldn`t find a good solution.
So, I would be very thankful if anyone could give a nice hint!
Thanks.
5 REPLIES
melvyn burnard
Honored Contributor

Re: ProLiant Server 380DL

Not sure what this has to do with HP-UX, moving to a more appropriate forum
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Steven E. Protter
Exalted Contributor

Re: ProLiant Server 380DL

Shalom,

Sounds like a Linux question. Good thing I know a bit about it.

1] Remove any lines in /etc/modules.conf that reference eth0, eth1, or
bonding, then add the following lines

alias bond0 bonding
options bond0 primary=eth0 mode=1 miimon=200
alias eth0 bcm5700
alias eth1 bcm5700


2] Create a file named /etc/sysconfig/network-scripts/ifcfg-bond0 containing
the following (change the addresses for your particular environment):

DEVICE=bond0
IPADDR=192.168.1.1
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
BOOTPROTO=none
USERCTL=no


3] Create a file named /etc/sysconfig/network-scripts/ifcfg-eth0 containing
the following:

DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none


4] Create a file named /etc/sysconfig/network-scripts/ifcfg-eth1 containing
the following:

DEVICE=eth1
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

Restart networking. Restart server to test it works on boot.

As last I checked active-active bonding only works on Intel NICS.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Christian Schniering
Occasional Visitor

Re: ProLiant Server 380DL

No sorry,

it isn't a Unix Problem.
The OS that is installes is Windows Server 2003 R2. So there must be a setting which "teams" the two networkadapters into one.
But I cannot find those settings.

sandeep_raman
Honored Contributor

Re: ProLiant Server 380DL

chongkan
Trusted Contributor

Re: ProLiant Server 380DL

Hey, what you think it is a Second NIC integrated NIC port is in fact the iLO port, for NIC teamming you should use a PCI NIC card, then, install latest PSP (Drivers), latest NCU (Network Configuration Utility)

After installing this you'll get the NCU icon on the taskbar, open it, select both NICs and create a NIC teaming for NIC Load Balancing (Incomming traffic Only). NCU will create a Virtual MAC address and you will be able to assing a single IP to both NICs as if they were only one.

For Outgoing traffic with NIC teaming, you'll need a different switch..

http://h18000.www1.hp.com/products/servers/networking/teaming.html