ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem running SPP 2018/03 on Gen9 Server

cesarpegado
Valued Contributor

Problem running SPP 2018/03 on Gen9 Server

I've gone to use the latest SPP which has only just come out on a Gen 9 server to update the firmware on the server, but i keep getting the following error when i mount the SPP through virtual media (iLO) 

It gets the screen where you can select interactive or automatic update, and then it crashes out with

alloc magic is broken at 0x5a537780: 84008fa4
Aborted. Press any key to exit.

Just wondering if anyone else has also had this error?

14 REPLIES
Torsten.
Acclaimed Contributor

Re: Problem running SPP 2018/03 on Gen9 Server

Did you compare the MD5 sum?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
ahe
Occasional Visitor

Re: Problem running SPP 2018/03 on Gen9 Server

I actually have a similar issue. I tried the base iso as well as a custom iso just for the servers I use. In both scenarios the iso boots when I use the ILO. In automatic mode it comes to "analyzing system, please wait" and after a few minutes it simply unmounts the iso and does a reboot with out installing anything. If I do it in manual mode and try to do the firmware update it tries to load the SUM, but fails after a minute or so and stays on the main menu. Nothing else happens. Diganistics etc. work fine.

I also tried putting everything on a USB stick and boot it from there. Exact same behavior. The server boots from the stick but does not update any firmware.

Any suggestions?

EDIT: I have several machines with the same hardware config and on none of these it works (DL160 Gen9). There are also no non-HP parts attached or installed on these servers.

 

Torsten.
Acclaimed Contributor

Re: Problem running SPP 2018/03 on Gen9 Server

I would check the md5 anyway, at the web page it is 2d1047b00f8cc5645fdc18596ad1183e.

This is matching my downloaded ISO:

I booted a virtual machine so far just for test and it worked. Maybe later tis day I will boot a server from.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Problem running SPP 2018/03 on Gen9 Server

updated a bl460c gen9 successfully.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
cesarpegado
Valued Contributor

Re: Problem running SPP 2018/03 on Gen9 Server

So i have the checed the MD5 and i get the same checksum so i know its good.

We have just deplyed some Gen10's with the same image and it worked fine. So i think its looking like its a comptability isse with server types, maybe components? I will carry on trying different things

ahe
Occasional Visitor

Re: Problem running SPP 2018/03 on Gen9 Server

So I tried it again on a DL380 Gen9 today and it also fails with the exact same error. I am currently not able to deploy the 2018.03.0 on any of my DL380 Gen9 or DL160 Gen9. The MD5 is the same and also the old 2017.10.1 does work fine through ILO or via USB stick.

Really no one elase haveing that issue with the 2018.03.0 SPP?

gsb88
Occasional Advisor

Re: Problem running SPP 2018/03 on Gen9 Server

I have updated both DL360s and DL380s Gen9 with SPP 2018/03 without issues. I use the USB key utility and let it all run from the USB stick. The one thing I am having trouble with is putting the just released Gen 8 bios on the USB key but that is a different issue.

Torsten.
Acclaimed Contributor

Re: Problem running SPP 2018/03 on Gen9 Server

>> The one thing I am having trouble with is putting the just released Gen 8 bios on the USB key but that is a different issue.

 

In theory it should work (put them in /packages directory), but SPP2018.03 is only supported for Gen9 and Gen10.

Latest SPP for Gen8 is SPPGen8.1.

There the files go into /hp/swpackages


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
gsb88
Occasional Advisor

Re: Problem running SPP 2018/03 on Gen9 Server

Torsten, I get it to show up as an additional package in "Inventory of baseline" but then in the "Inventory of LocalHost" it says that components have higher version than avaiable in baseline and there is nothing to update. Same issue in the 8.1 SPP or the 0318 SPP.

gsb88
Occasional Advisor

Re: Problem running SPP 2018/03 on Gen9 Server

Figured it out. Had the wrong P number bios. My dl360 Gen8 bios is P71 and I was trying P73. Got the P71 update and worked fine. All BIOS are not created equal.

Highlighted
Torsten.
Acclaimed Contributor

Re: Problem running SPP 2018/03 on Gen9 Server

In the past and even now there were/are different server lines like

ML/DL 100 - entry level

ML/DL 300 - "professional" etc ...

But there was an exception in Gen8:

No ML/DL100, but a ML/DL 300"e" and "p", were the "e" was the replacement for the ML/DL100 series.

Confusing ...

 

The P70 and similar in the BIOS naming is a code for the model family, here are some examples:

HP ProLiant DL380p Gen8 (P70)
HP ProLiant DL360p Gen8 (P71)
HP ProLiant ML350p Gen8 (P72)
HP ProLiant DL360e Gen8/DL380e Gen8 (P73)
HP ProLiant DL320e Gen8 v2 (P80)
HP ProLiant ML350e Gen8/ML350e Gen8 v2 (J02) 

 


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
gsb88
Occasional Advisor

Re: Problem running SPP 2018/03 on Gen9 Server

Thanks Torsten, that clears up the BIOS confusion.

mikldk
Advisor

Re: Problem running SPP 2018/03 on Gen9 Server

Just updated a HPE BL460c G9 with Windows Server 2016 with Hyper-V yesterday - running full load with 50 VM's today.

No issues so far.

I did run the HP SPP launch_sum.bat from mounted ISO inside OS.

Kind Regards Mikkel Knudsen
ahe
Occasional Visitor

Re: Problem running SPP 2018/03 on Gen9 Server

Not sure what HPE changed now, but by building a new custom SPP including the freshly released 2018.03.1 hotfix supplemental bundle, it works now for me on both DL380 Gen9 and DL160 Gen9. If I exclude that supplemental bundle it still fails.

For me that makes clear that there was an issue with the first release, but that is now resolved if the hotfix supplemental bundle is included.