ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with backup, I/O device error

Roman Lenarsic
Occasional Visitor

Problem with backup, I/O device error

Hi,

Our problem is related with backing up our Proliant DL380 G5 server to tape library HP MSL2024.
Library is connected to server over SCSI controller (PCIe, Ultra320).
Problem started immediately to appear when we plugged in HP/COMPAQ - STORAGEWORKS FC1242SR 4GB DUAL CHANNEL PCI-E FIBRE ADAPTER and installed its drivers, including Microsoft storport driver update KB932755.

Error is when we try to backup something to tape. After some GB is succesfully backuped we get error:
The request could not be performed because of an I/O device error. A hardware error occurred.

Beside already mentioned MS update we were trying to find a solution on MS forums, HP forums and of course Google.
We try several solution found on internet but unfortunately without help:
1. We try to update all drivers, all patches for windows,...
2. We try to install latest HP Proliant Support Pack
3. We try to reconfigure HP SIM agents
4. We try to uninstall all HP SIM agents

We try to reproduce this problem on two different servers, two different tape drives. Same problems.
We get problems immediately after installing FC drivers and Microsoft storport driver update KB932755.

We are using Symantec backup exec, similar problems also with HP Data protector.

Anybody has a solution for this ?
Best regards
Roman Lenarsic
2 REPLIES
Rob Buxton
Honored Contributor

Re: Problem with backup, I/O device error

What's the FC1242SR connected to?
Is that where the storage being backed up from is connected to?
If so, I'd check the FW level of the FC1242, this is a QLogic based card, so also get hold of SANSurfer. Install the main GUI on a suitable desktop and the agent on the server. You can use this to check out the FW version and update it if reqd - check the QLogic site for FW.
Otherwise I'm not sure how the FC is involved.

I'd leave the PSP / HP Agents intact. they shouldn't cause issues.

If data is coming across from disks via the FC then I wonder if the speed is overloading the ML? have you checked FW versions on that?
Roman Lenarsic
Occasional Visitor

Re: Problem with backup, I/O device error

Hi,

FC controller is not connected yet to any FC switch.
All firmware are the latest, including:
- firmware for FC controller
- firmware for tape drives and libraries
- firmware for all controlers and HP servers

We are trying to solve this problem three weeks now, without success. We have no idea any more.

Best regards,
Roman Lenarsic