HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

 
J.Carlos.Saavedra
Occasional Visitor

Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

Hi all,

I am desperate with a server performance problem since it was mounting in February and still with no solution from HP with more than 100 hours lost making tests. The server is a ML350 G5 with RAID 5 and Windows SBS 2003 R2 SP2 as operative system. The server is used as a simple file server but networks applications work slower than the old ML350 G3 that was replaced by this.
By example, a simple write operation takes from 5 to 30 seconds to finish and the application seems to get freeze for a while. We have test network, cabling, switch, and more but do not find any solution. It seems a problem caused by e200i controller, because we found a very low performance, but HP technicians said that tests gave good performance for the server.

I do not know which is the problem, perhaps the RAID 5 with this controller, Windows 2003 SBS R2 SP2 in this server, ... I am frustrated and I have lost more than 5 months and more than 100-200 hours working with this issue with no results. I need help, please. I have read others posts with problems like this with no solution, anybody could help me?

Which is the best RAID configuration for this server?.

Performance tests for disk gave worst results than a ML115 or a simple PC. Is it a nice performance?

Best regards,

Juan Carlos
8 REPLIES
u84823
Regular Advisor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

Could you post some test results and detail the client machine and interconnecting network?

Re E200. Do you have the battery backed write cache installed (BBWC)?

Re write performance, is it so bad copying locally (i.e. CD to hard disk), or just over the network?

Thanks
TTr
Honored Contributor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

What was the raid setup on the old server? Which controller, what type of disks (SAS/SATA), how many disks and what raid level?

On the new server need same info as well.
J.Carlos.Saavedra
Occasional Visitor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

Thank you for all responses.

The server is a ML350 G5 4 GB RAM 3 X 146 SAS disks RAID 5 e200i controller with 128 MB(BBWC).

The operative system is Windows SBS 2003 R2 SP2, that was very difficult to install due to a error with the contained Service Pack in the HP branded CDs.

Well, after install and configure the server, network domain, users, shared folders, etc, I found that network applications worked slowly, b.e. a new record write took 5-10 seconds to finish, so I contacted with Microsoft to advice this problem. All tests did not found any network problem, so continued with test in the server. I found worst disks perfomance that a ML115, or a simple PC. I called to HP in Spain and opened a support case. Lots of tests after and lots of technicians as well, we only found that disks performance was horrible in some tests, b.e. 2 Mb/sec. The most common performance disk was 10-20Mb/sec.

I seek HP to raise the case level and contact me a HP engineer. After some tests by him and some reports by me, a copy between folders and units gave 20Mbs/sec in the last test and he indicates me that the server performance is not bad, but the problem still and it is not a solution. I respect his opinion but I do not understand why this problem can not be resolved by lots of HP technicians and engineers and less during 5 months.

Which is the problem?. After five months I am not sure which is the answer.

I found some forum posts with this problem in Internet, including others operative systems and virtualization platforms, and I never found a definitive solution.

I am not sure Windows SBS 2003 R2 SP2 is not appropiated for this server, RAID 5 with BBWC has a horrible performance for a file server, or perhaps network adapter performance had to be configured specially in this server.

I am lost in desperation, but I am very frustrated due the results by HP after 5 months of tests and hundred of hours lost looking for a single problem.

I am thinking to test a clean Windows 2003 server standard O.S intallation, or change the RAID 5 to another RAID configuration, or something that gives the server a normal performance as a simple file server.

Regards,

Juan Carlos
u84823
Regular Advisor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

We need to userstand whether the problem is present only from other network devices or also within the machine (i.e. copy a cd-rom to hard disk on the server).

From what you have said it sounds like it is network access that is the problem, in which case it is synmptomatic of a duplex mismatch between the server NIC and the switch.

Hope that helps.
J.Carlos.Saavedra
Occasional Visitor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

All tests gave a 20 Mbs maximum performance copying data between different disks and folders and curiosly between an external USB disk and internal disks it was similar.

I tested it with different disk benchmark tools and found very low performance in write operations sometimes (2 Mb/sec). The write cache has not effect, we got similar results with and without it. The RAID stripe was change from 64K to 32K with no results.

I want to know if it is possible to connect a single SATA disk to this server and install a clean operative system to test if Windows SBS 2003 R2 SP2 is the problem.

The applications run fast in the server, but very slow in the network workstations.

Regards,

Juan Carlos.
J.Carlos.Saavedra
Occasional Visitor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

The network switch is a 3Com Gigabit switch and there was not problems with the same workstations and the old ML350 G3 that was replaced by the new one.

I did not found problems in the network but if you want to test something it will be a good idea, because I do not want to let any test as passed.

Regards,

Juan Carlos
u84823
Regular Advisor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

It looks increasingly like a network configuration issue to me. I would change the physical network cable first.

Next look at the switch. Have any of the ports been set to anything other than auto-negotiate? Plug the server in an auto-negotiate port.

Next check the HP network config. Set the adapter to auto/auto (speed/duplex). If no difference set it to 100Mbps/HALF duplex and retest.

HTH
J.Carlos.Saavedra
Occasional Visitor

Re: Problem without solution. ML350 G5 server with RAID 5 as a simple file server.

Only was added to the network the new server, a new router and 2 cords to connect network and ILO2 adapter in the new server to the network switch. I did not found any problem evidence in the network but it is could be necessary to test with other network switch and cords. I remember to had tested it before but it is a good idea to do it again.

Regards,

Juan Carlos