ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems booting up G5 servers after firmware upgrades

dumol
Frequent Visitor

Problems booting up G5 servers after firmware upgrades

Hi all,

 

We have a few Proliant  DL380 G5 servers with P400 storage arrays. After an issue with the battery in the storage array for one of them we decided to upgrade firmware for the storage arrays and BIOS for all the servers. The firmware upgrades went fine and now they are all up to date with the BIOS and storage array firmwares.

 

However, booting problems started to appear with most of them some days/weeks later. POST checks are just fine but they fail to boot the operating system with this message:

 

Attempting Boot From Hard Drive (C:)

 

The operating system on all of them is Ubuntu Linux 12.04 and reinstalling GRUB2 to the MBR of the first logical drive, althought successfully, doesn't solve this issue. I have to mention these installations used to boot with no such problems with the same GRUB2 configuration.  More so, for some of the servers this booting problem appeared intermittenly, only from time to time, not for every boot. And one of the servers is currently not booting from CD-ROM either (using the Virtual Media applet from iLO2).

 

4 REPLIES
dumol
Frequent Visitor

Re: Problems booting up G5 servers after firmware upgrades

I should add that on the servers that boot from CD-ROM through the Virtual Media applet from iLO2 I'm able to chroot into the existing installations and everything works as expected. I'm able to reinstall GRUB to the MBR of the first logical drive in every possible way without any error (using the live CD, using the grub-install or grub-setup from the chroot'ed partition etc.). Shooting in the dark I have even tried to install GRUB2 to the MBR of the other logical drives.

 

On one of these servers I've even deleted all logical drives except the one holding the root partition for the existing Ubuntu Linux installation. I've even forced installing GRUB2 to the boot partition from this single logical drive as seen here: http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/ML350-G3-Attempting-to-boot-from-hard-drive-c-hanging/m-p/5112137#M119241

 

All in vain, unfortunately... Any help would be much appreciated!

dumol
Frequent Visitor

Re: Problems booting up G5 servers after firmware upgrades

I should mention I've also checked the BIOS settings, messed with the IPL boot order and controller order in every possible way. I have even reset the BIOS settings on one of the servers with no result whatsoever. All this in addition to trying to boot with the backup ROM versions on all the servers with boot problems.

 

Also, on one of the affected servers (the one that won't boot from CD-ROM either) I've had some filesystem errors at last successful boot. Maybe this one has some more serious issues...

dumol
Frequent Visitor

Re: Problems booting up G5 servers after firmware upgrades

This turned out to be a misterious  Grub2 issue that was triggered by the storage array firmware upgrade. The moment we replaced Grub2 with Extlinux on affected servers, booting problems dissappeared for good. This has been verified for three servers which started having boot problems over the past three months.

Bigeasy
Occasional Visitor

Re: Problems booting up G5 servers after firmware upgrades

It apears i am having this same issue, after upgrading Bios. How do you replaced Grub2 with Extlinux on affected servers ?  i am running Esxi 5.0 and i get the message  " Attempting Boot From Hard Drive (C:) , boot error "   i have an hp dl580 G5 . thanks