ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Proliant DL580 and Red Hat Advanced Server

Tony Rossomano_2
Occasional Contributor

Problems with Proliant DL580 and Red Hat Advanced Server

Hello, we're having some problems configuring/installing Red Hat Advanced Server 2.1 on a Proliant DL580 Server w/ smart array controller (640x, 64x, 5i,5300 Series). I don't have the actual model number of the raid controller on hand, but I know it's in the aforementioned series. Anyways, we're having a boot order problem with the internal smart array and the external smart array drives.
During the Red Hat install, in the drive partitioning phase using disk druid, both arrays show up correctly (/dev/ida and /dev/cciss), but the external drive (/dev/cciss) shows up first in the list. We partition the disks, setting up mount points on both disk arrays. We place the common mount points on /dev/ida (/boot, /, swap, etc) and a few others on /dev/cciss.
When we get to the boat loader phase of install, the choices are:

1) Install boot loader to Master Boot Record of /dev/cciss/c0d0

2) Install boot loader to first segment of /boot on /dev/ida

We really want to install the boat loader to the master boot record of /dev/ida/c0d0, there is no option to change the drive order (like in Red Hat 8.0 - Advanced boot loader options). So we've tried both of the options above with no luck. When we boot-up, we simply get the word "GRUB" or "LILO" in the upper left-hand corner of the screen, and that's it. We've tried changing the drive boot order in the BIOS and still no luck.
We removed the external controller and we were able to successfully install Advanced Server. We thought we would simply install without the external controller and just add the card after linux was already installed, but then we couldn't figure out how to partition the drive at that point (fdisk didn't recognize /dev/cciss). It doesn't appear to be a driver issue, because linux correctly identifies both disk arrays. Maybe we didn't correctly change the drive order in the BIOS. I don't know. Any ideas/suggestions would be greatly appreciated.

Thanks,

Tony

1 REPLY
Sunil Jerath
Honored Contributor

Re: Problems with Proliant DL580 and Red Hat Advanced Server

Hi Tony,
here's a way you'll be able to proceed with your install. First make sure that the controller that will hold the /home partition is the first one in the boot controller order. Then proceed with the installation and isntall the lilo boot loader. You can then pick any partition for installing the boot record (as we are going to change this later on to the correct one which is /dev/cciss) Make sure to create the boot floppy at the end of the installation. You can then boot up your system, and edit the file called /etc/modules.conf and make sure that the controllers in this lists are in the correct order, with the controller holding the /boot partition being first. You can then recreate a new ramdisk image using the command mkinitrd (see manual page for help) and then reinstall lilo on the correct partition (again see man page of lilo for help) This will allow you to boot your system without a floppy for consequent boots.
Regards,