ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant 140 G2 + RHEL 4 + SATA Hard disks

Ángel Gutiérrez Rodrígu
Occasional Advisor

Proliant 140 G2 + RHEL 4 + SATA Hard disks

The server has 2 Maxtor hard disks

During the normal operation of server, it starts sending this in /var/log/messgaes:

Dec 21 12:51:01 yed23 kernel: ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
Dec 21 12:51:01 yed23 kernel: ata1.00: cmd ca/00:08:25:3d:6d/00:00:00:00:00/e3 tag 0 cdb 0x0 data 4096 out
Dec 21 12:51:01 yed23 kernel: res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
Dec 21 12:51:06 yed23 kernel: ata1: soft resetting port
Dec 21 12:51:06 yed23 kernel: ata1.00: configured for UDMA/100
Dec 21 12:51:06 yed23 kernel: ata1: EH complete
Dec 21 12:51:19 yed23 kernel: SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
Dec 21 12:51:19 yed23 kernel: SCSI device sda: drive cache: write through

And becomes unaccessible. Entering though iLo:

EMS> SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138808
Read-error on swap-device (8:0:82138816)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138816
Read-error on swap-device (8:0:82138824)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138824
Read-error on swap-device (8:0:82138832)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138832
Read-error on swap-device (8:0:82138840)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138840
Read-error on swap-device (8:0:82138848)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138848
Read-error on swap-device (8:0:82138856)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138856
Read-error on swap-device (8:0:82138864)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138864
Read-error on swap-device (8:0:82138872)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138872
Read-error on swap-device (8:0:82138880)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138880
Read-error on swap-device (8:0:82138888)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138888
Read-error on swap-device (8:0:82138896)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138896
Read-error on swap-device (8:0:82138904)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138904
Read-error on swap-device (8:0:82138912)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138912
Read-error on swap-device (8:0:82138920)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138920
Read-error on swap-device (8:0:82138928)
SCSI error : <0 0 0 0> return code = 0x40000
end_request: I/O error, dev sda, sector 82138928
Read-error on swap-device (8:0:82138936)

EXT3-fs error (devicesda2): ext3_findentry: reading directory #357568 offset 0

This has been happening in one node of 50. Mainboard has been changed, the 2 SATA disks have been changed as well as the cables.

Before changing disks, sometimes, they even disappeared form the BIOS menu. After replacing disks they never disappeared from the BIOS menu. But problem with the SATA remains.

Anybody has a clue about it?

Thanks in advance,
Á.



3 REPLIES
TarunJain
Respected Contributor

Re: Proliant 140 G2 + RHEL 4 + SATA Hard disks

Dear à ngel Gutiérrez Rodríguez,

I'm not having a solution but let me share some info.
We had a XC3000 cluster with similar machines & similar issue.
Do u also have the same setup.
If yes then kindly update the firmwares to the latest.
The frequency should be diminished & keep in touch with hp support (Server+Cluster) for any permanant resolution

Hope this info would help

TarunJain
Ángel Gutiérrez Rodrígu
Occasional Advisor

Re: Proliant 140 G2 + RHEL 4 + SATA Hard disks

Finally, problem solved. After changing all (I guess it was all) the hardware while the problem remaint, it got solved when one of the two processors was changed. No problem since that.

TarunJain
Respected Contributor

Re: Proliant 140 G2 + RHEL 4 + SATA Hard disks

Thanks for returning & sharing the info with the Forum.
Appreciated.