ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant 360 G2 and SmartStart 6.00

Eric Stéphan
Occasional Visitor

Proliant 360 G2 and SmartStart 6.00

Hello,

I've upgraded smartstart 5.4 to 6.0 on a proliant G2 and I've got an error message in the windows event viewer : event 1010 Perflib :
The Collect Procedure for the "Tcpip" service in DLL "C:\WINNT\system32\Perfctrs.dll" generated an exception or returned an invalid status. Performance data returned by counter DLL will be not be returned in Perf Data Block. Exception or status code returned is DWORD 0.

Any idea ?

Thanks

Eric
20 REPLIES
Mark Cloutier
Respected Contributor

Re: Proliant 360 G2 and SmartStart 6.00

Dear Eric,
Please re-apply SP2 for W2K.
But do not reboot. Make sure to rerun SmartStart 6.0 and reinstall the drivers for the Array/SCSI controllers. SP2 might overwrite the drivers.

Mark
We are here for a good time, not a long time!
Kretz
Occasional Contributor

Re: Proliant 360 G2 and SmartStart 6.00

Hello.

I've installed Windows 2000 with Smartstart 7.1 ! Since the installation in the application log of the server the same error message described above from eric appears. Should i do the same workaro
GoM
Melinda Cooper
Frequent Advisor

Re: Proliant 360 G2 and SmartStart 6.00

We have six DL360, G2's four of them have W2K, SP3 and were built with Smartstart 6.0 and I'm getting the same error. Two DL360, G2's have W2K, SP2 and also built with Smartstart 6.0 and I'm not getting the event 1010 Perflib application error. I had a feeling it might have to do with the Broadcom Nic7780 that is in all six of these machines. So far I've not been able to resolve this problem. Did what the other person suggest work? I also heard that Compaq was working on a fix for this.
Martin Aberg
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

It's the new NIC's that causes the problem. Have had it verified with Compaq and Broadcom are working on a new driver. Probably ready late march.
All machines with NIC 7780 driver 2.75 are having the same problems. Both DL360 and DL580.

/Martin
Steve Dolap
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

I have an older Proliant 6400 with CPQ 3131 NIC and after updating all the drivers with SupportPaq 5.5 the perlib errors started to appear. So that shoots down the theory that it is only happening with the Broadcom NICs.

I've also noticed that when you install the WIN2K + SP2 without any Compaq drivers the log is clean. Once you run 5.5 and newer, the perflib errors start to appear.

I have about 10+ Proliant DL360 G2 servers which are all having the problems. I have G1 servers as well that have the same errors.

Anything that I upgrade with the newer CPQ drivers starts to display the error.

Steve Dolap
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

Correction to my last note. It's Win2k + SP3.

The 6400 has NT 4.0 + SP6a.
David Howell_4
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

I found another HP Resource Centre Reply.

This basically points the problem to a registry setting that disables performance counters for the tcpip service.

Set the following registry in your registry:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Performance] "Disable Performance Counters"=dword:00000000


For the full story:

http://bizforums.itrc.hp.com/cm/QuestionAnswer/1,,0x28235bd3782dd711abdc0090277a778c,00.html


Regards,

Dave :o)

Terry Hutchings
Honored Contributor

Re: Proliant 360 G2 and SmartStart 6.00

MS is going to be releasing a KB article on this shortly, which will be Q318663. This will require getting a Pre-SP4 hotfix. I'd also recommend looking at Q186713 and looking at the second paragraph up from the bottom.

This issue may be able to be temporarily resolved by using SP20958.exe:
http://h18007.www1.hp.com/support/files/evoworkstation/us/download/14684.html
If you're planning on using teaming, then I wouldn't recommend using this driver.
The truth is out there, but I forgot the URL..
Steve Dolap
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

I tried that disable performance counters fix and it doesn't work. just waiting on that pre-sp4 hotfix now.
Jim Gaites
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

I've tried EVERYTHING in the above, and nothing fixes this problem. Also, the DWORD reverts to 1 every time I reboot. If anyone knows how to fix this, please email me.
jeff go
Frequent Advisor

Re: Proliant 360 G2 and SmartStart 6.00

I am running Smartstart 6 on a DL380 G3...and I am seeing this error..

my question is:
will this cause the server to lose network connectivity?
if it aint broke, dont fix it
Waldmeier
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

Delete the "open" entry in key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Performance] that should help, in my case it did.
You don't need to reboot.
Delete the "open" entry in key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Performance] this helped in my case
Jens Baumann_2
Frequent Advisor

Re: Proliant 360 G2 and SmartStart 6.00

You might also want to have a look at this: http://support.microsoft.com/?kbid=300956
Kibaiya
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

Waldmeier,
You suggested deleting the open key in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Performance].
What does this key do? How does deleting it resolve the problem? I am just trying to have an understanding so that I can explain it to my group.

Thank you
David in Tennessee
Frequent Advisor

Re: Proliant 360 G2 and SmartStart 6.00

Jay Heidecker
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

I was having the same issue running Win2k and support pack 6.20 or 6.20A (Cant Remember) where the counter would keep getting disabled at reboot. Solved it by installing latest version of Network Teaming and Configuration 7.20.720.86 B.. Enabled the counter and restarted, everything is fine now.
Tillman
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

Terry Tals about the
MS-Q318663 Does anybody know when MS releases this pre-sp4 hotfix?

Greetings,
Lars
Is 'dumbo' written on my forehead?
Steve Dolap
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

I tried the Extensible Counter List utility which didn't work for me.

Guess I just have to wait for SP4 or the hotfix.

This is annoying.
Martin Moses
Occasional Visitor

Re: Proliant 360 G2 and SmartStart 6.00

Anyone tried the new gigabit NC77xx drivers V6.34.0.0 dated may 30, 2003 ?
Melinda Cooper
Frequent Advisor

Re: Proliant 360 G2 and SmartStart 6.00

I've tried the following to remove the perflib problem on our DL360, G2 machines:

SP3 - didn't help
exctrist.exe - didn't help
SP4 - didn't help
CP002876.exe (Compaq HP) - didn't help

So I'm also at a loss as to what to do next. I see theres some drivers for the NIC7780 (V6.34.00) which I haven't tried.

Melinda