ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant DL 580 G2 - Red Hat Enterprise Linux 4 Installation question

 
SOLVED
Go to solution
bytescorpion
Occasional Contributor

Proliant DL 580 G2 - Red Hat Enterprise Linux 4 Installation question

Hi,

I have a DL 580 G2 that had Red Hat 2.1. I'd like to install RHEL 4 on it. My support contract has ended long ago, so I want to work on it on my own.

I'd like to know if I have to upgrade any firmware/ROM on the system before I can install RHEL 4 successfully. I am also using HP Storage Works Modular SAN Array 1000 with the server.

I'd like to know if this would work fine with RHEL 4, or I need to do any ROM/Firmware upgrades on the HBA/RAID Controller as well.

Please advise

Thanks
4 REPLIES
Víctor Cespón
Honored Contributor
Solution

Re: Proliant DL 580 G2 - Red Hat Enterprise Linux 4 Installation question

bytescorpion
Occasional Contributor

Re: Proliant DL 580 G2 - Red Hat Enterprise Linux 4 Installation question

Thanks. How do I go about finding the firmware. Is it the HBA firmware or the RAID controller firmware?

How do I find out the step-by-step procedure?

Can I first install RHEL 4 and then later upgrade the firmware?

Do I need to upgrade any other firmware/ROM?
Pl advise

Best regards
~sesh
Esteemed Contributor

Re: Proliant DL 580 G2 - Red Hat Enterprise Linux 4 Installation question

The recommended way to go about it, is to install the latest firmware using the firmware maintenance CD first, and then install the Operating System (RHEL 4).

This way you can ensure that you don't leave any components with older version.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=uk&prodTypeId=15351&prodSeriesId=316533&prodNameId=3288116&swEnvOID=2025&swLang=8&mode=2&taskId=135&swItem=MTX-26a0f9e294764a91b76b282f2a
Víctor Cespón
Honored Contributor

Re: Proliant DL 580 G2 - Red Hat Enterprise Linux 4 Installation question

Firmware maintenance CD will update everything on the server (BIOS, NIC, SmatArray, ILO, ...). The MSA needs to be updated separately.

Check these threads:

http://forums12.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1201099808542+28353475&threadId=1191049

http://forums11.itrc.hp.com/service/forums/questionanswer.do;HP-FORUMS-S-WPA-IDX=HNHTnqTp1MHJ0yD23rsNw2vLr9CRXGXXyT3tKWvbKjBgS8BCnGBQ!134078868!935694600?threadId=1182188

Uodate all firmware before installing RHEL 4