ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant DL360 G8 & Server 2012R2

 
SOLVED
Go to solution
rgrace
Frequent Advisor

Proliant DL360 G8 & Server 2012R2

Just bought 2 new Proliant DL360 G8's

 

Trying to install MS Server 2012R2 & having issues getting the servers to work

 

The OS installs no problem but after a reboot or two, it won't work anymore. The Server 2012 startup logo appears & then you get a light blue screen (not BSOD) indicating Server 2012 has encountered a problem & cannot load & reboots

 

AHCI SATA Controller - V0.84

B320i Storage Array - V5.54, HBA Firmware 15.10.05.00, ROM Ver 07.25.05.00

 

Do I need a upgrade or downgrade in some firmware?

 

There must be someone who has had sucess installing Server 2012R2 on one of these models

 

Been fighting this for a few days now

 

Any Help appreciated

17 REPLIES 17
waaronb
Respected Contributor

Re: Proliant DL360 G8 & Server 2012R2

Some of the basic Windows startup troubleshooting techniques might get you pointed in the right direction. Hit F8 when Windows is starting up so you can select some options there, like not auto-rebooting, or to debug the startup.

Hopefully you'll be able to see the error message or the specific driver it was loading when it had a problem.

You could also try a safe boot in case it's some other program or driver doing something.

As the above post suggests, make sure you have the latest drivers for everything. I've only used the P420 controllers on the Gen8 boxes which work fine, so I don't know if there's anything specific to the Bxxx models to look out for. I saw someone mention making sure it's set to AHCI mode in the ROM setup, but other than that, I have no idea. :)
rgrace
Frequent Advisor

Re: Proliant DL360 G8 & Server 2012R2

None of that works

 

I updated all the firmware on the servers

 

Did the OS install from DVD boot & used the suggested Smart Array Driver driver

 

One server was able to boot several times but after being powered off for an hr or so, would not boot into Windows. Just would get the Server2012 logo & then blue/teal screen as before

 

The other server took 4 tries to get the OS to boot without blue screen & only lasted 2 more restarts before again blue screening

 

Getting very tempted to send the servers back

 

 

rgrace
Frequent Advisor

Re: Proliant DL360 G8 & Server 2012R2

I did manage to get a blue screen that actually gave me an error message

 

PAGE_FAULT_IN_NONPAGED_AREA (libsa.sys)

 

 

find out this file is part of the driver for the B320i starage array along with hpsa2.sys

 

 

waaronb
Respected Contributor

Re: Proliant DL360 G8 & Server 2012R2

You might try doing the intelligent provisioning to install Windows. It should make sure any boot drivers are installed. I don't use the intelligent provisioning myself, but it seems like it's the equivalent of the old Smartstart setup method. It's just built into the server now, no need to boot off a separate CD.

On my DL380p Gen8 servers with a P420i and add-on P420 controller, I'm able to boot off a Windows Server 2012 R2 DVD and install it directly without any issues, so I think you're on the right trail with the B320i controller not being detected correctly when using the default driver from Microsoft.

Instead of using the intelligent provision install, you could also boot from the Windows disk and go through the steps to install a custom storage driver. Grab the latest B320i drivers from the HP downloads and use those. Intelligent Provisioning install seems easier though.
rgrace
Frequent Advisor

Re: Proliant DL360 G8 & Server 2012R2

Mixed results trying to get the servers to run. Didn't matter if you used the Intelligent Provisioning or a standard install to try & get the OS to boot after install.

 

Managed to get them to boot after OS install after many attempts. Ran the latest Proliant service pack & it  updated all the firmware & latest drivers

 

Could get them to reboot 5-7times & things were looking hopeful but that was dashed & the blue screen would appear.

 

Would get the same message as before if you did an F8 & select no auto reboot

 

PAGE FAULT IN NONPAGED AREA (libsa.sys)

 

That file is part of the driver for the array. I am using the latest - ver 62.10.0.64

 

After several attempts at a restart, you would get the auto repair screen but it appeared not to be able to see the array

 

Wasted 10+days trying to get these blasted servers running

waaronb
Respected Contributor

Re: Proliant DL360 G8 & Server 2012R2

Unfortunately I'm just not familiar with the B320 controllers... I don't have any direct experience with them.

I don't know if any of the information in this link would help, but it could be worth double-checking the AHCI mode you're using and see if anything else is useful:
http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/docDisplay/?spf_p.tpst=kbDocDisplay&spf_p.prp_kbDocDisplay=wsrp-navigationalState%3DdocId%253Demr_na-c03871499-1%257CdocLocale%253D%257CcalledBy%253D&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken
rgrace
Frequent Advisor

Re: Proliant DL360 G8 & Server 2012R2

Made the change you sugested & did an OS reinstall thru the Intelligent Provision


The 1st server looked promising but would "blue screen" on every 2nd reboot

 

The other server justs goes into the OS recover mode on every restart. Can never get the OS to fully load

 

Dmitry_Morozov
Occasional Visitor

Re: Proliant DL360 G8 & Server 2012R2

Was hanging on this for about 4 days (2012R2 @ 360e Gen8 + B320i), but finally have solved it! 

Original solution is here - yeah, it's all the 2012R2 update about. So boot your server with pressing F8 and choose "Disable Early Launch Anti-Malware Protection". Server will boot normally. Then install hotfix KB2966870. Next rebooting will run normal.