ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant ML370 Loud Fan

Ken Fine
Occasional Visitor

Proliant ML370 Loud Fan

I have a proliant ml370 p3-1000. Running Redhat Linux 7.3.

The fans are constantly running at their highest speed. Which is way to loud. The server is in a well cooled room it has great ventalation. (not crammed in a corner or under a desk). Is there anything I can do to get the fans to run slower or even to replace them with a quieter fan?

I am running the latest system rom (P17 12/18/02). I also have the lastest hp server management drivers and agents for 7.3 installed and running.

cmahealthd is listed as one of the process's that are running. Is there any configuration files that I may be missing? I can't find any settings the let you control the fans directly or is this not even possible? Any help would be appreciated.
Thanks
3 REPLIES
Sunil Jerath
Honored Contributor

Re: Proliant ML370 Loud Fan

Hello Ken,
Have you tried lowering the speed in the BIOS utilities as well?? Some of the new server do have a setting in the BIOS. Please have a look at that.

Regards,

Re: Proliant ML370 Loud Fan

Hi Ken,

In the Microsoft and Netware world the ML370 G1 fans reduce there speed when cpqhealth gets loaded. I had a look for the setup in Redhat and came up with this procedure (See below. Although it may be older than 7.3, the basics should be the same. Hope this helps.

Brian

Well now let begin installing and configuring the agents. First lets install the health driver, which is required by the agents.

# rpm -qa Uvh cpqhealth-2.1.0-11.Redhat7_1.i386.rpm
Preparing... (100%)########################################### [100%]
1:cpqhealth (100%)########################################### [100%]
Fixing up cpqeisaid...
Fixing up cpqrom...
..cpqrom started.
Fixing up cpqhealth...
..cpqhealth started.


Ken Fine
Occasional Visitor

Re: Proliant ML370 Loud Fan

Thanks for your replies.

I couldn't find anything regarding fan speed in the bios. There is a startup speed setting with the AUTO, and HIGH option. I'm not sure whether this is for the fan or not but I have tried both settings.

cpqhealth: the redhat 7.1 cpqhealth doesn't run on 7.3. The version that does run on 7.3 installs with the hp server managment and drivers utilites. (hpasm) and runs a process called cmahealthd. Which does run at startup on this server.

Any other ideas?