ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant ML370 + SmartArray642

FRANGHIAS
Occasional Visitor

Proliant ML370 + SmartArray642

Hi Guys,
I have a Compaq Proliant with a smartArray 642 Raid Card. My operating System is Linux Red Hat 8. I have 3 scsi drives.
On the first one (36GB, RAID 0) the system is installed.
On the second and the 3rd (2x72GB Raid 0+1) I have some data.
I'd like to swap my 2 datas drives (raid 0+1) with four drives (146Gb Raid 5).
When i plug the 4 new disk and go to the ORCA menu, it says : No logical Drives detected.
Ok so lets create the Raid5 logical device on the 4 new drives.
But wen i reboot, my system is unable to boot..
I have to boot with a live CD ( i m running Linux) and rebuild the partition table ( thanks god i ve written the part table on a paper beofre doing the opération)
And when i m trying to boot, my system is still unable to boot..
Why ? Becos the first partition of my first disk has been deleted (/dev/cciss/c0d0p1 = /boot )
Ok it s not a problem, on my live Cd there is the Time Navigator software, so i can restore data. Lets restore /bin.. Done, then rebuild LiLo. Done.
Lets reboot and it s ok!
But if i can change the drives and reboot safely, i will need to restore the data through network. I ve experienced some problem while restorign data..
Wut if i need to plug out my 4 drives and plug in the ol' 2 drives ?
Ok lets doing it : It says : No logical drives.
Ok lets create em ( 1 = RAID 0 and 2 = RAID 0+1 on 2 physical drive)
ALways the same stuff, impossible to boot..
Lets rebuild the partition table, lets reboot ..
Impossible .. Lets restore the first partition on the first partition of the first drive (/dev/cciss/c0d0p1)
Lets reboot, it s ok.
BUT !!
It also delete the first partition of the second drive (/dev/cciss/c0d1p1)

Does anybody knows how to avoid this problem ?
Why it delete the first partition of each disk ???

Excuse my english, i used to be quite fluent, but i feel soooo rusty this morning !! Not enough practicizing !! ^^
Thanks a lot !
Matt
2 REPLIES
RaMpaNTe
Trusted Contributor

Re: Proliant ML370 + SmartArray642

Hi FRANGHIAS here's a workaround you can do. Well I would need more information first, which generation is your server.

Now, the following process is a bit faster but Iâ ll tell the long process as well.

The faster process is, make a tape backup of your data {second and the 3rd hdd (2x72GB Raid 0+1)} remove those drives, boot the server using the Smart Start CD, go to the maintenance tab, then go to ACU (array configuration utility) delete the remaining part of the array (RAID 0+1) DONâ T delete the array which contains the OS.

Put the new drives in your server, again boot from the Smart Start CD, go to the maintenance tab and then to the ACU and create your RAID 5, once the raid is created go ahead and restore the data. Make sure that the RAID in which your OS is installed is the RAID A and the RAID 5 is marked a RAID B, if not thatâ s why you canâ t boot into your OS, because the RAID marked as â Aâ is the only one that can be used to boot.

The other way (the long one) to do this is as follows:

Leave the drives as they are now, same configuration that you have, put 2x 146 GB HDDs in your server, boot using the Smart Start CD, go to the maintenance tab and then go to ACU, make a migration from RAID 0+1 to a RAID 5, wait until the migration is done, this can take 15 minutes per gig.

Once the migration is done go ahead and remove 1x 72GB HDD and replace it with 1x 146GB hdd, wait for the rebuild process, again this can take 15 to 20 minutes per gig. Once the rebuild is done go ahead and do the same thing with the remaining drive.

Now we have a RAID 5 with 4HDDs and a logical drive of 216GB, and in order to use the total 438GB in your logical drive, you can go to the ACU and extend the logical drive to the maximum allowed once this process is finished youâ ll have your RAID 5 using its maximum capacity.

Best Regards.
RaMpaNTe
You heve a question... I have an aswer!!!
FRANGHIAS
Occasional Visitor

Re: Proliant ML370 + SmartArray642

Hey Guy,
Thanks u soooo much for ur reply !!!
I ve found that bootable cd ( am such a n00b)
and set up my Raid with it ! It works so well now !
Omg u know wut ? Tonite i m gonna celebrate that and u can be sure i ll have a beer in the name of Rampante :D
Thank u so f***ing muuch !!
Rock on Dude !!!!!