ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant ML570 with RedHat Linux 7.2, CDROM read problems

Proliant ML570 with RedHat Linux 7.2, CDROM read problems

Hello
I have a proliant ML570 with RedHat Linux 7.2 server edition, when i copy from the CDROM to the HARD DISK, appears the next message
"Mar 5 20:16:00 HostName kernel:cdrom:This disk doesn't have any tracks i recognize"
I suspect that it is a SCSI problem but i am not sure.
Could you tell me any idea?.
The proliant is new, it has 4 hard disks Ultra3 SCSI, 1 alone and 3 in RAID 0 by software.
Santiago Flores
5 REPLIES

Re: Proliant ML570 with RedHat Linux 7.2, CDROM read problems

who has produced the cdorm? (it comes from an iso image/from a boxed RedHat/...)

Have you verified that the cdrom is ok? (md5sum)

Can you read the cdrom in another machine?

how do you try to copy the cdropm to the harddisk?

where do you see the error?

Re: Proliant ML570 with RedHat Linux 7.2, CDROM read problems

I am trying to install the oracle's
e-bussiness suit and it started but did not finish, then i tryied to copy the CDRom infomation to the hard disk the but it only copy about 30 MB and shows the next error
Mar 5 20:42:39 dffeesvlirhsx01 kernel: cdrom: This disc doesn't have
any tracks
I recognize!

Mar 5 20:20:39 dffeesvlrhs01 kernel: ide_dmaproc: chipset supported
ide_dma_los
tirq func only: 13
Mar 5 20:20:39 dffeesvlrhs01 kernel: hda: lost interrupt
Mar 5 20:21:52 dffeesvlrhs01 kernel: ide_dmaproc: chipset supported
ide_dma_los
tirq func only: 13
Mar 5 20:21:52 dffeesvlrhs01 kernel: hda: lost interrupt
my cdrom come whit the server and the OS shows it like
compaq CRD-8202B
when we use a cat /proc/ide/cda, the output is
driver ide_cdrom version 4.59

We are using RedHat advanced server 2.1

After this we tryied to copy another disk but it is the same problem, the strange is that que used the CDROM when qe installed the OS and it didn't show us any error message


I hope you can help me
Thanks

Santiago Flores

Re: Proliant ML570 with RedHat Linux 7.2, CDROM read problems

If the CDROM media are OK, then I'll try using a different CDROM reader. Somehow, the contents from the cd-rom are not being read. This can mean:

- bad media (cd-rom)
- bad drive (cd-reader
- bad cables (cd-reader to controller)
- bad controller (uh oh)

Do some tests with this information and tell us your results.


All the ebst.
Josep

Re: Proliant ML570 with RedHat Linux 7.2, CDROM read problems

At first, i have two ML570 with the same things and the same problem with the CDROM also the cards and disks distribution are the same. I am using one of the servers for probes and the other is now working with oracle.

In the oribes server, I reinstalled yesterday night the O.S (RedHat Linux Advanced Server 2.1) using the CDROM and it was right, it only took 30 minutes and copied about 1.7 GB, then i booted the server and tryied to do a copy from CDROM to Hard Disk but it was so slow (2 MB in 2 minutes), when i did a scanpci de output was

pci bus 0x0 cardnum 0x00 function 0x0000: vendor 0x1166 device 0x0008
Device unknown
pci bus 0x0 cardnum 0x00 function 0x0001: vendor 0x1166 device 0x0008
Device unknown
pci bus 0x0 cardnum 0x00 function 0x0002: vendor 0x1166 device 0x0006
Device unknown
pci bus 0x0 cardnum 0x00 function 0x0003: vendor 0x1166 device 0x0006
Device unknown
pci bus 0x0 cardnum 0x03 function 0x0000: vendor 0x0e11 device 0xa0f0
Compaq Device unknown
pci bus 0x0 cardnum 0x04 function 0x0000: vendor 0x1000 device 0x000a
NCR Device unknown
pci bus 0x0 cardnum 0x04 function 0x0001: vendor 0x1000 device 0x000a
NCR Device unknown
pci bus 0x0 cardnum 0x05 function 0x0000: vendor 0x1002 device 0x4756
ATI Mach64 GV
pci bus 0x0 cardnum 0x0f function 0x0000: vendor 0x1166 device 0x0200
Device unknown
pci bus 0x0 cardnum 0x0f function 0x0001: vendor 0x1166 device 0x0211
Device unknown
pci bus 0x2 cardnum 0x05 function 0x0000: vendor 0x0e11 device 0xa0f7
Compaq Device unknown
pci bus 0x2 cardnum 0x06 function 0x0000: vendor 0x8086 device 0x1229
Intel 82557/8/9 10/100MBit network controller
pci bus 0x7 cardnum 0x05 function 0x0000: vendor 0x0e11 device 0xa0f7
Compaq Device unknown
pci bus 0x7 cardnum 0x07 function 0x0000: vendor 0x9005 device 0x00c0
Adaptec Device unknown
pci bus 0x7 cardnum 0x07 function 0x0001: vendor 0x9005 device 0x00c0
Adaptec Devi

I have only one Ultra 3 SCSI dual channel card connected to a DAT 40/20
1x18.2 GB Hard disk alone
3x36.4 GB Hard disks in RAID 0 by S.O.

Either i tryied to use the DAT with a backup tape, i used the command

tar -tv

but it didn't do anything in 5 minutes and i had to press Ctrl-C to return the prompt

I don??t think that cable or CDROM unit are the problem because i don't have problem while i install the OS, the problem only appears when the O.S. is installed

I thing that it could be conflict with IRQ beetwen the ultra 3 SCSI adapter and the CDROM but i haven't tryied it.

If it is not correct, do you have another idea?

Thank you
Santiago Flores

Re: Proliant ML570 with RedHat Linux 7.2, CDROM read problems

Try this:

put the cd-rom on the drive, *unmounted*.

then, create an image from the cd-rom with dd command:

$ dd if=/dev/hda of=/tmp/image.iso

(I assume that your CD drive is in /dev/hda . I also assume that you have eough space on /tmp directory. modify this to suit your needs)

if you get errors, something is wrong (RedHat not properly identifying your chipset/scsi controller?)

If you don't get errors, you end with an image file with the contents of the cd-rom. You can mount the image and treat it like a CD-drive:

$ mount -o loop /tmp/image.iso /mnt/disk

(make sure /mnt/disk exists)

The contents of the CD-ROM will be available (read only) in such directory

Hope this helps