ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant Support Pack 7 on W2k3

Jerry Debner
Advisor

Proliant Support Pack 7 on W2k3

We run installs from both an unattend (from CD)method and a syspreped image based process (network based). Our CD based process works perfectly everytime. We cycle through a vbs script that checks to see if it is an HP machine, and if so runs the bpxxx.cmd from c:\apps\compaq directory.

Our sysprep process calls this same vbs script and runs through the install of the PSP using the bpxxx.cmd from the same c:\apps\compaq directory (so all of this is local, just the initiation of the script is remote) - this is what fails. I also changed to directly call the bpxxx.cmd file directly via this process - this fails as well.

Items such as the smart array 5/6 and the ilo and nic drivers load ok, it is the services that fail. None are started. The folder that is suppose to exist in c:\winnt\system32\cpqmgmt folder does not get created, thus all the service installs such as version control, foundation agents all fail.

The log file only shows "The operation was not successful"

On the Insight Manager Agents, I do get error reporting error installing the inf section..
.\cqmghost\cqmghost.inf - this list continues with 7 more errors.

When I run this script locally again via the vbs script from start/run, it runs ok.

any idea? I'm at a loss. Thanks for your help.
3 REPLIES
Robert Romanczuk
Occasional Visitor

Re: Proliant Support Pack 7 on W2k3

I am seeing this same issue on multiple machines. The cp004188.exe (Insight Management Agents 7.10 for Windows 2000/2003) package installs fine when logging into the system and running it manually on either W2K or W2K3. However installing cp004188.exe via SMS on W2K3 is failing and leaving errors in the log as noted below, yet is succesful via SMS on W2K. Has anyone found a resolution for this type of error?

There was an error installing the following INF Section:
.\cqmghost\cqmghost.inf - [DefaultInstall]

There was an error installing the following INF Section:
.\cqmghost\cimntfy\cimntfy.inf - [DefaultInstall]

There was an error installing the following INF Section:
.\cqmghost\webagent\cpqwmgmt.inf - [DefaultInstall]

There was an error installing the following INF Section:
.\cqmgnics\cpqnimgt.inf - [DefaultInstall]

There was an error installing the following INF Section:
.\cqmgstor\cqmgstor.inf - [DefaultInstall]

There was an error installing the following INF Section:
.\cqmgserv\cqmgserv.inf - [DefaultInstall]

There was an error installing the file: install.inf
Jerry Debner
Advisor

Re: Proliant Support Pack 7 on W2k3

In my further testing, I determined our solution. We use ADS (Microsoft Automated Deployment Services) for our build process. ADS has an agent that runs in the OS. The fix was that we had to set the ADS Admin agent to run the service interactively with the desktop. Once we did this, it has run properly every time since. I assume there is an SMS agent that you make a similar change on.

Hope this helps.
Szabolcs Petho_1
Regular Advisor

Re: Proliant Support Pack 7 on W2k3

I have another similar situation but the problem for me doesn't seem to be deterministic. From about 10 PSP 7.30->PSP 7.40 upgrade installation it happened only on one server. I have also problem with the HP Insight Management Agents for Windows 2000/Windows Server 2003 (English (US), Japanese) component. After the failed status PSP upgrade install if I tried again installing this component alone it said it is already 7.40. Then I tried with force option and the installation failed again with the
"There was en error installing the following INF Section:
.\cqmgserv\cqmgserv.inf - [DefaultInstall]"
message. Then I checked the server and found SNMP and all the HP Insight agents (4 pieces) services were stopped. I started them and again send the installation with the force option than it succeeded and said reboot required.