ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

RAID 5 parity initialization trouble

Mike King_4
Occasional Visitor

RAID 5 parity initialization trouble

Well, i upgraded to 4 73GB drives from three and tried to restore my database. Now when i did this with the three disks i had no problem restoring the database while the parity was initializing. The Tape Drive is on a seperate SCSI card. This time this is the error i kept getting

"BackupTapeFile::SkipBlocks: SetTapePosition failure on backup device '\\.\Tape0'. Operating system error 1111(The I/O bus was reset.).

When i changed to a RAID 1+0 it is now doing the restore although both my recent tapes are reading incomplete even though they were both verified complete. I tried them both while i was fighting with it.

So here's my question, do i need to buy 4 new drives and let them initialize parity before i move the database, this is a business critical server that can't be down for more than 8 hours and its going to take all day tomorrow just to catch up the imports!
2 REPLIES
Imad
Advisor

Re: RAID 5 parity initialization trouble

Mike,

RAID5 parity initialization has to finish before using the new space in W2K, if I expand the existing array.

But if I creat a new array, then I don't need to wait for it until it finishes initialization, and I can use the new space.

Regards,
Mike King_4
Occasional Visitor

Re: RAID 5 parity initialization trouble

Well its 34 hours later, haven't slept and its finally fixed. a damn scsi cable to the tape drive was the culprit. my last words of believing i was through it were a laugh. Anyway thanks !!