HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

RHEL 6 support for Proliant DL585 and DL585 G2

 
SOLVED
Go to solution
martin_g_1
Occasional Contributor

RHEL 6 support for Proliant DL585 and DL585 G2

Hi all,

our servers (Proliant DL585 and DL585 G2) are running under RHEL4 but according to RH annoucements they will no longer support RHEL4.

Therefore our plan is to skip RHEL5 and move directly to RHEL6. But without the correct drivers it would be probably imposible...

For DL585 and DL585 G2 I can find only drivers for RHEL5 so far, but for example DL585 G7 there are drivers for RHEL 6.

Can you help me where I can find whether DL585 and DL585 G2 will be supported also for RHEL6? And if yes, then when I can expect the drivers to be available for download?

Thank you.

Martin
7 REPLIES
Johan Guldmyr
Honored Contributor
Solution

Re: RHEL 6 support for Proliant DL585 and DL585 G2

Hey, see here:

http://h18004.www1.hp.com/products/servers/linux/hplinuxcert.html

DL585 G2 and G1 is supported on RHEL 5 and below.

Do you have to have RHEL6 drivers? Won't the ones from 5 work on 6?

Also for RHEL6:

"HP has certified and will support these servers with the following caveats:

SAN Support Pending"
martin_g_1
Occasional Contributor

Re: RHEL 6 support for Proliant DL585 and DL585 G2

Thank you for the link!
The support for RHEL6 for DL585 and DL585 G2 is not even planned :(

I have a bad experience with installing 'standard' software for older versions of RHEL in newer ones. Therefore I was not even thinking about doing it with the drivers...
Do you have some experience with using drivers for RHEL5 in RHEL6? Is it safe?
Johan Guldmyr
Honored Contributor

Re: RHEL 6 support for Proliant DL585 and DL585 G2

I do not have experience with RHEL5 drivers on RHEL6, maybe somebody else who sees this post does though.

Have you considered a virtual machine and have RHEL6 in there?

On the link above there is a link for VMWare. 4.1 is OK on DL585 G2.
G1 is not listed there and on VMWare's page ( http://www.vmware.com/resources/compatibility/search.php ) it is certified for up to 3.5 U5.
martin_g_1
Occasional Contributor

Re: RHEL 6 support for Proliant DL585 and DL585 G2

We use the servers for scientific simulations. They require as much CPU and RAM performance as available. I am afraid that using virtual machine will significantly reduce the 'useable' performance...

Considering the situation with RHEL6 support I think we will move to RHEL5 'only'...

Thank you once again for the help!
SMR
Valued Contributor

Re: RHEL 6 support for Proliant DL585 and DL585 G2

The 585/G2's may not officially support RHEL6 but I don't see why they wouldn't. The drivers are and will be there for a while. The 585 I believe has a standard Broadcom Gb controller which uses the tg3 driver and the 585 G2 has a Broadcom Multifunction NIC which uses the bnx2 driver, the smart array controller uses the cciss. They won't be certified since neither HP nor RH have any interest in certifying old hardware... that said... I would stick to RHEL 5 if you're madly concerned about stability.

Cheers!
martin_g_1
Occasional Contributor

Re: RHEL 6 support for Proliant DL585 and DL585 G2

SMR, when you are speaking about drivers (tg3, bnx2, cciss) you have in mind drivers in 'standard' distribution of RHEL6 or did you mean that drivers for newer servers for RHEL6 should be backward compatible?
SMR
Valued Contributor

Re: RHEL 6 support for Proliant DL585 and DL585 G2

Martin,

I mean the standard distro drivers but yes, drivers for newer servers should be backward compatible.