HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Raid 6 logical drive says rebuilding 0% after 3 weeks

 
Steve Ledoux
Occasional Advisor

Raid 6 logical drive says rebuilding 0% after 3 weeks

A 250gb sata drive has been replaced in our 10 disk logical drive. The array configuration manager says that the logical array is rebuilding still after 3 weeks at 0%.
Surely it can't take 3 weeks to rebuild the array.
Should I just pull the disk? The manuals say not to pull the disk while it is rebuilding.

Any help appreciated
12 REPLIES
KarloChacon
Honored Contributor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

server model?
controller type?

Didn't your momma teach you to say thanks!
Steve Ledoux
Occasional Advisor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

It's a DL320s with a smart array P400 controller, 2 logical drives, 2 physical drives in the first array and 10 in the second array.

Thanks
KarloChacon
Honored Contributor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

would you mind posting the an screen of the %%%%

and also the array diagnostic utility report
Didn't your momma teach you to say thanks!
KarloChacon
Honored Contributor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

BTW

you can try taking it out and put it back again
to try to force the rebuild again
Didn't your momma teach you to say thanks!
Steve Ledoux
Occasional Advisor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

Thanks Karlo

Is it safe to to remove the drive while it is still building? That was my original plan but I didn't want to kill the server.
Roberto-italy
Occasional Visitor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

Do you have data on this logical drive?

I think that the rebuild process was compromise and you can wait 1 year but nothing can change!

If you have data, you should backup before pull the disk...but in any case you should pull all disk and repat the the procedure.
May be before re-try to build new logical drive with 10 disk, is better than you tray to build a new logical drive with 2 or more disk but not with 10 disk.
In this way you can check is the controller are working well or there are problem with it.

Roberto
Italy
Steve Ledoux
Occasional Advisor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

Hello

I have atached the array diagnostic report.

Thanks again
KarloChacon
Honored Contributor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

try this

update the firmware for your controller to latest

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=3232017&prodNameId=3288100&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=MTX-b0d856a9528445aeb7a7bd4e7f

update the array configuration utility
your server got a pretty old version

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=3232017&prodNameId=3288100&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=MTX-456bf556d9df4cae8bec6e2cc3

and after that take the HDD out and put it back in

if you feel a bit nervous
turn off the server remove the HDD and put it back in but that is kinda "no way" since they are HOT PLUG

so I recommend you remove it and put it back in when you reboot the server after updating you p400 controller after updating the firmware can help you to reactivate the rebuild process
Didn't your momma teach you to say thanks!
Steve Ledoux
Occasional Advisor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

Have installed updates and firmware, taken disk out and reinserted once rebooted, disk says that it is rebuilding but still on 0% after 24 hours.
KarloChacon
Honored Contributor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

would you mind upload it ADU report again after the updates?

thanks
Didn't your momma teach you to say thanks!
Steve Ledoux
Occasional Advisor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

I have attached a new ADU scan.

Thanks again for all your help
KarloChacon
Honored Contributor

Re: Raid 6 logical drive says rebuilding 0% after 3 weeks

sorry my answer is too late

kinda busy today

OK what I found was this HDD

Physical Drive 1I:1:5 -> The data on the physical drive is being rebuilt.

it is having Recovers Failed Read I think this is the HDD you replaced OK try this replacing the HDD with another one if that does not fix the issue replace HDD backplane

Didn't your momma teach you to say thanks!