ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Recovery for non-functioning iLO2 firmware fails

 
Thomas Rauser
Occasional Collector

Recovery for non-functioning iLO2 firmware fails

Hi everybody,

 

I've tried to flush a damaged iLO firmware as described from HP as discribed:

 

SUPPORT COMMUNICATION - CUSTOMER ADVISORY

Document ID: c01850906

 

RECOVERY PROCESS FOR NON-FUNCTIONING iLO 2 FIRMWARE

HP ProLiant DL and ProLiant ML Series Servers

If a ProLiant DL or ProLiant ML series server is power-cycled with a non-working iLO 2 firmware and takes several minutes to display the Power-On Self-Test (POST), perform the following steps to recover iLO 2 to Firmware Version 2.05:

  1. Set the iLO 2 Security Override Switch on the system board to the ON position. The location of the switch is printed on a label located on the inside of the hood cover.
  2. Power ON the server and boot using the HP Smart Update Firmware DVD Version 9.30. The DVD ISO image is available for download from the following URL:

    http://www.hp.com/go/foundation

  3. Use the following key strokes to exit out of HP Smart Update Manager. A command prompt will be displayed over the HP Smart Update Manager window. The command prompt takes approximately 30 seconds to appear:

    CTRL + ALT + d + b + x (Keep the CTRL and ALT keys pressed when typing d b x )
  4. At the command prompt, navigate to the HP Smart Update Firmware DVD directory containing the supplemental iLO 2 firmware update by using the following command:

    bash-3.1# cd mnt/cdrom/hp/swpackages
  5. Use the following command to unload the HPILO module:

    rmmod hpilo
  6. Use the following command to execute the iLO 2 firmware update in direct mode:

    sh CP014256.scexe direct (This parameter requires two dash ( ) characters).
  7. Once the iLO 2 firmware upgrade is completed, power OFF the server and set the iLO 2 Security Override Switch on the system board to the OFF position.
After a long time, HP Smart Update Manager starts. but I could not exit with the [CTRL + ALT] + [d] + [b] +[x]. By trial I got a xterm, but only numbers and special characters are working. If I tried to type letters, nothing happens on the xterm.

Now my question, have somebody succsessfully recovert iLO firmware on a HP DL380 G5 as discribed above? Please give me an hint, what mistake I could have done.

Thank you very much in advance.
Greetings, Thomas
2 REPLIES
Oscar A. Perez
Honored Contributor

Re: Recovery for non-functioning iLO2 firmware fails

As soon as the Firmware DVD begins booting up, it ask you to select "Automatic" or "Interactive" mode. Try selecting "Interactive" mode and after you select language, agree to the license and the main interface shows up, press and hold CTRL ALT and type d b x.




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
gorbisia
Occasional Visitor

Re: Recovery for non-functioning iLO2 firmware fails

Hi,

I have a similart issue:

iLo2 1.50 corrupted during update (was stuck at 2% for 40 minutes and then I've decided to refresh the page)

 

Set the security override switch to ON.

Booted the server using the 9.30 DVD into Interactive Update mode...

CTRL+ALT, d, b, x

rmmod hpilo

sh CP014256.scexe --direct  (also tried CP011535 for iLo 1.79)

"y" to confirm that I do want to upgrade the firmware.

 

and then, it looks like it's working, since it says "Programming offset 00000000...", but it's really not.

After a while it fails with a "Timeout to Erase" (see attached photo).

 

Has anyone ever successfully restored a corrupted iLO2?