ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Red Hat 9 install problem in Proliant ML330 G2

 
Miguel Lagos_1
Occasional Contributor

Red Hat 9 install problem in Proliant ML330 G2

I want to install RH9 in Proliant ML330 G2

Configuration:

- Integrated Ata Raid Controller

- Two IDE Hard Disks RAID 1 (both master)

- IDE CD-ROM to IDE Controller as master.

Problem: RH9 boots from the CD but after loading the kernel appears the message:
"The Red Hat CD was not found in any of your CDROM drives. Please insert the Red Hat Linux CD and press OK to retry."

I tried "boot: linux hde=cdrom", but it doesn't work.

The CD is good (I tested it in another computer).

Please help me!!!


Miguel Lagos
5 REPLIES
Darren Webb
Advisor

Re: Red Hat 9 install problem in Proliant ML330 G2

Hi there,

I have the same problem on a ML 370.

I have tried the following commands also;

boot: linux hda=cdrom
boot: linux hdb=cdrom
boot: linux hdc=cdrom
boot: linux hdd=cdrom
boot: linux hda=nodma

Could do with some help....
Anyone?
Jong Kim_1
Advisor

Re: Red Hat 9 install problem in Proliant ML330 G2

I had same problem with ML330 G3(Flashback). Yours ML330 G2(SOB). First, I changed BIOS "boot OS" to Linux. It's MS Windows by default. and then you will have problem with RAID card. I don't remember what it was for G2 but it's megaraid for G3. You have to add drivers during initial set up.
Have you tried Fedora? I know that works
Clay Long
Occasional Visitor

Re: Red Hat 9 install problem in Proliant ML330 G2

I have the same setup, however I have installed Fedora2 from cd (w/o problems) and now when attempting to boot to the HDD the screen simply prints "GRUB " and halts. I think this has something to do with the IDE/RAID controller.

Also, i read somewhere that this particular raid controller is in fact NOT a true raid controller, rather is is an IDE controller with hooks to which a piece of software (windows software, generally) attaches to make a software RAID that looks like hardware raid. Fedora2 install saw through this, and detected both drives despite the RAID configuration.

Any additional thoughts? I do not think that this G2 raid card is the megaide... but I am not sure.
HGN
Honored Contributor

Re: Red Hat 9 install problem in Proliant ML330 G2

Hi

We had a similar problem when installing RedHat AS 2.1

When contacted HP they said that it will work with Update 2 CD (Actually we tried installing using the Update 1 & 3 both failed for the reason we had Update 1 which we ahd been using and then we thought we would try the latest Update 3)

When installing you need to supply the drive diskette only then this will sense the Hard drive.

Hope this helps

Rgds

Gopi
Clay Long
Occasional Visitor

Re: Red Hat 9 install problem in Proliant ML330 G2

I think i figured out the problem that I am having. Here it goes:

I cannot get the computer to boot from the onboard IDE controller. I disabled the additional controller, configured the BIOS to boot to the "onboard ide controller", set the C drive to the top of the list, and it never boots. Tried different HDDs, different channel configurations, different OS, etc. So I gave up trying.

The "RAID" card is the only option. I can boot from the CD (which is connected to the onboard IDE, btw), and Fedora detects both HDDs connected to the raid controller, despite the raid config. I go ahead and install Fedora to the drives, making hda contain / and hdc contain swap and /home. Install grub, and everything goes fine. When i reboot for the first time, the RAID controller squaks about loosing configuraiton. I assume this is b/c the config is written to the disks, which is then overwritten by the format/install of the disks by fedora. So, the RAID controller INSISTS on setting up a new config. Once the config is written to the disks, the boot attempt fails and the word "GRUB" is printed, nothing else. I am guessing that the RAID config is messing up the MBR.

I tried a GRUB boot disk, however the grub disk cannot see the drives on the RAID card... probably a lack of drivers. So i cannot see the dirves to boot to them.

So, until I can get the onboard IDE to boot to a HDD, or I can get the RAID card to stop writing configs to the HDD, or I can get the grub disk to see the raid card, i will not be able to use this computer for Fedora.

Who's idea was this IDE Software-Hardware RAID/NIC/VIdeo card anyway? Why not just throw on a modem and a sound card and make it a distant relative of the Aztec cards? :)

Any ideas on how to do one of the three things I need to do to get this thing to work??? I would hate to have to laod windows just because....

Thanks.