ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Replaced hard disk not added to array

Ian Flood_2
Occasional Advisor

Replaced hard disk not added to array

I have a DL760 using a 5300 array controller using RAID5. One hard disk failed so the array automatically rebuilt the on-line spare. When the failed drive was replaced with an identical drive the array did not re-assign it as a new on-line spare. The replaced drive is only seen as a seperate drive to the original array. All firmware has been updated, the onboard Array card has been disabled. The O/S is using Win2003. Any ideas how i can get the array to see the replaced drive without rebuilding the server?
7 REPLIES
Frank Dittberner
Occasional Visitor

Re: Replaced hard disk not added to array

I think you must assign your new drive as a new hot-spare. If you want that this new drive ist in your array and your old drive should be hot-spare then assign the new drive as hot-spare, plug-out the old drive hot-spare, and plug in and assign as hot-spare.
As always, do backups.
Ian Flood_2
Occasional Advisor

Re: Replaced hard disk not added to array

I cant, the array will only see this new drive as a seperate logical drive. It still thinks the failed drive is part of the array.
Tv_3
Respected Contributor

Re: Replaced hard disk not added to array

Call HP services.

Probably the disk is a few sectors smaller than the original one.

They have to ship you another disk.

I had this issue, and the only sollution was that HP assigned me an other disk, after the new disk was added, the array has rebuilded succesfully.

Greetzzzzz
Chaos, Panic or Disaster??? Always Stay Calm, I will fix it.
Ian Flood_2
Occasional Advisor

Re: Replaced hard disk not added to array

Have attached a screen shot which gives more info
Terry Hutchings
Honored Contributor

Re: Replaced hard disk not added to array

By looking at the screen shot, it appears the drive wasn't added back to the machine in the same location. The replacement was added at some id (not visible) on port 2 and the original failed drive was installed on port 1, id 1.
The truth is out there, but I forgot the URL..
Andrzej Kowalik
Honored Contributor

Re: Replaced hard disk not added to array

Ian,
wait until rebuilding process finish. It's look like rebuilding RAID5 in original location - I think you do not have option to change disk location, only for drives capable cage ;)
Can you see progress bar or rebuilding status when you click on Array A and then more information?
regards,
Andrzej
Ian Flood_2
Occasional Advisor

Re: Replaced hard disk not added to array

As the drive failed over night the array rebuilt the spare. When the failed drive was replaced the machine did not recognise the replacement from the start. I did not build the original array. Are there any utilities that will allow me to change the port \ scsi id's of the drives in the array?
It is obviouse that the problem is due to the fact that the array says the failed drive is port 1 and the rest of the drives including the replacement are all listed as port 2.