ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

SATA Raid 1 problem on ML110G4

 
Nextel
Occasional Visitor

SATA Raid 1 problem on ML110G4

Hallo,

we have just bught a HP Proliant Server, model ML110 G4, with two 160GB Sata HDs configured in Raid 1 on the integrated controller (Ctrl-S at the startup to set the Raid configuration), as I can see during the boot.

Tying to install CentOS 4.4, that is the RedHat Enterprise Linux clone (so RHEL 4.4), I faced some problems in recognizing the raid configuration.

In fact the Linux installer detects correctly the controller but it shows me two separate hard drives, /dev/sda and /dev/sdb in the partition tool window each of more or less 150GB, instead of just on single HD of 150GB.

I have tried to add the latest HP Embedded SATA RAID Controller Driver for Red Hat Enterprise Linux 4 (x86), version 1.2.5571-1 (19 Nov 06), downloading the floppy image from the ML110 support site (http://h18023.www1.hp.com/support/files/server/us/download/25814.html) and launching the Linux installation with the command "linux updates dd", but after having mounted correctly the floppy and read the drivers I got the error message "No devices of the appropriate type were found on this driver disk ...", as it does not find any suitable driver on the floppy.

On the BIOS options I can see that the SATA RAID is enabled.


How can I proceed in order to allow Linux to detect that the two SATA discs are in Raid 1 configuration, and not two separate devices?


Thanks in advance for your support and please do not hesitate to contact me for any additional information.

Regards,