ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

SCSI Drive not booting after firmware upgrade

AndreasK
Occasional Visitor

SCSI Drive not booting after firmware upgrade

Hi All,

I'm in the process of upgrading the storage system of an ML350 G4 server and need to upgrade the firmware on a couple of drives. Currently a single drive runs off the on-board SI SCSI controller, so i installed a SA641 controller, connected the backplane to that and updated the firmware. To test if the upgrade was successful, i then reconnected the backplane to the onboard SCSI however now the HDD will not boot into windows.
It is detected and I can still see the active partitions if i boot into drive image.

Any help is much appreciated, Thanks
3 REPLIES
Rob Leadbeater
Honored Contributor

Re: SCSI Drive not booting after firmware upgrade

Hi,

It sounds as though the SmartArray controller may have become the default boot device rather than the original SCSI card.

You should find an option in the RBSU to set the Boot Controller order...

Hope this helps,

Regards,

Rob
AndreasK
Occasional Visitor

Re: SCSI Drive not booting after firmware upgrade

Hi Rob,

thanks for the reply, that was my initial thought however in the RBSU, the boot order is:

on-board SCSI channel 0
other PCI boot device
on-board SCSI channel 1
SmartArray 641

On another note, the on-board controller detects the drive and assigns SCSI ID 0. Is this correct?

Regards,
Andreas
AndreasK
Occasional Visitor

Re: SCSI Drive not booting after firmware upgrade

...as an update, when I insert another HDD that was imaged from the original before the firmware upgrade, it boots fine.