ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

SPP Gen8.1 contains older HPE Broadcom 1Gb Driver/firm than available, newer version also supported?

 
grimson
Advisor

SPP Gen8.1 contains older HPE Broadcom 1Gb Driver/firm than available, newer version also supported?

Hi,

OS Windows Server 2016 on DL380 Gen8

SPP Gen8.1 comes with this (older) driver and firmware versions;
-HPE Broadcom 1Gb Driver for Windows Server x64 Editions v17.4.0.0(B) (24 Oct 2016)
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_d07f1f998bcc40f2a912f37c7f

-HPE Broadcom NX1 Online Firmware Upgrade Utility for Windows Server x64 Editions v5.0.0.24 (24 Oct 2016)
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_2ab6d25c9afd48adbc98838d77


When I click revision history I can download and install succesfully these later versions;
-HPE Broadcom 1Gb Driver for Windows Server x64 Editions v20.6.0.5 (25 Sep 2017)
-HPE Broadcom NX1 Online Firmware Upgrade Utility for Windows Server x64 Editions v5.1.1.0 (25 Sep 2017)

If i navigate to this collection of Gen8 drivers I get the same 'older' drivers.
https://support.hpe.com/hpsc/doc/public/display?docLocale=null&docId=emr_na-c05029449&sp4ts.oid=7271241


I assume the installer has logic to detect if installed on a SUPPORTED server so because this installer DOES install it seems to be 'supported' on a Gen8 server. Also, I think its normal to click on revisions to choose the latest version available.
But because the PSP is an tested bundle my question is, is this later version of the HPE Broadcom 1Gb Driver and Firmware supported on a Gen8?

I would stress the fact that the installer doesn't prohibit the install on a Gen8 server and therefore if used in a mixed Gen8 and Gen9 environment you could accidentally install these drivers on a Gen8.

So are these drivers supported or not? :)

Regards,
Arian van der Pijl