ProLiant Servers (ML,DL,SL)

SUM 8.7.0: Unable to download pre-requisite component

 
mschlossarek
Advisor

SUM 8.7.0: Unable to download pre-requisite component

SUM 8.7.0 throws "Unable to download pre-requisite component" errors while running smartupdate upgrade.

DL380 Gen10 (RHEL 7, ilo5 2.30):

 

 

[root@Gen10~]# smartupdate upgrade
sum : Smart Update Manager Version 8.7.0
Model: ProLiant DL380 Gen10, ROM: U30, ROM Version: 04/08/2020
----------------------------------------------------------------------------------------
Searching for firmware..................................................................
Analyzing results.......................................................................

Unable to download pre-requisite component 'firmware-ilo5-sha512-2.30-1.1.x86_64'
Unable to download pre-requisite component 'firmware-ilo5-1.48-1.1.x86_64'
Warning: Installing the latest available iLO version requires the minimum iLO 1.4x version and sha512-2.x component to be installed on the server which is not available in the currently configured repo.
Warning: SUM requires minimum version of HPE Smart Array P824i-p MR Gen10 driver to be installed and active to discover and update hard drives connected behind HPE Smart Array P824i-p MR Gen10. Install the driver, reboot the server and re-run SUM to update HDDs

To allow SUM to proceed, use: smartupdate upgrade --ignore-warnings

 

 

 

 

DL380 Gen9 (RHEL 7, ilo4 2.75):

 

 

[root@Gen9~]# smartupdate upgrade
sum : Smart Update Manager Version 8.7.0
Model: ProLiant DL380 Gen9, ROM: P89, ROM Version: 10/21/2019
----------------------------------------------------------------------------------------
Searching for firmware..................................................................
Analyzing results.......................................................................

 

Unable to download pre-requisite component 'firmware-ilo5-sha512-2.30-1.1.x86_64'
Unable to download pre-requisite component 'firmware-ilo5-1.48-1.1.x86_64'
Warning: Installing the latest available iLO version requires the minimum iLO 1.4x version and sha512-2.x component to be installed on the server which is not available in the currently configured repo.

 

The following firmware will be applied:
N/A

 


The following firmware will be skipped (Use --downgrade or use --rewrite to apply.)
    Online ROM Flash for Linux - Advanced Power Capping Microcontroller Firmware for HPE Gen9 Servers   [1.0.9]
    Supplemental Update / Online ROM Flash Component for Linux (x64) - Smart Array and Smart HBA H240ar, H240nr, H240, H241, H244br, P240nr, P244br, P246br, P440ar, P440, P441, P542D, P741m, P840, P840ar, and  P841   [7.00]
    Online ROM Flash Component for Linux - HPE Integrated Lights-Out 4   [2.75]
    Online ROM Flash Component for Linux - HPE ProLiant DL380 Gen9/DL360 Gen9 (P89) Servers   [P89 2.76 - (10/21/2019)]
    HPE Broadcom NX1 Online Firmware Upgrade Utility for Linux x86_64   [2.26.1]

 

 

 

 

Both mentioned components/packages (firmware-ilo5-sha512-2.30-1.1.x86_64 and firmware-ilo5-1.48-1.1.x86_64) cannot be found in the official repositories: 

https://downloads.linux.hpe.com/SDR/repo/spp/RHEL/7Server/x86_64/2020.09.0/ 
https://downloads.linux.hpe.com/SDR/repo/spp/RHEL/7Server/x86_64/current/
https://downloads.linux.hpe.com/SDR/repo/fwpp/rhel/7/x86_64/2020.09.0/
https://downloads.linux.hpe.com/SDR/repo/fwpp/rhel/7/x86_64/current/

 

Why are these components/packages are needed?
What are these sha512 versions of ilo?
Why does smartupdate complains about missing ilo5 components/packages on a Gen9 server?

"Historisch gewachsen."
2 REPLIES 2
Torsten.
Acclaimed Contributor

Re: SUM 8.7.0: Unable to download pre-requisite component

Running from SPP 2020.09?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
mschlossarek
Advisor

Re: SUM 8.7.0: Unable to download pre-requisite component

Running SUM 8.7.0 from https://downloads.linux.hpe.com/SDR/repo/hpsum/rhel/7Server/x86_64/current/ with packages from SPP 2020.09 - yes. 

"Historisch gewachsen."