ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Setup IPMI on HP DL 380 G8

Aldih
Occasional Contributor

Setup IPMI on HP DL 380 G8

Hi,
Does anyone know how to setup IPMI on server HP DL 380 G8? Also i implemented RHEL 6.3 With high availability add on and i have done for cluster those servers. Now i want to use fence by using IPMI on server. However, these servers has no license ILO so that's why i need to know how to enable it.
Actually i have done configure IPMI by using ipmitool, and also i can check the chassis power status, but i cannot check chassis power status on another server by remote IPMI. Seems that i cannot ping interface on ipmi.
Is it something miss what i've done? Should i check on the BIOS level?

Thanks,
Aldi
11 REPLIES
Ali
HPE Pro

Re: Setup IPMI on HP DL 380 G8

Hi,

 

HP iLO Management Engine comes standard on all HP ProLiant Gen8 servers. Please refer to Server Quickspecs for more info:

http://h18004.www1.hp.com/products/quickspecs/14212_div/14212_div.HTML

 

 

1. Turn ON the Server, press F8 key at the Integrated Lights-Out (iLO) prompt.
2. If prompted to Enter user name and Password, use the information you found on iLO tag.
3. From iLO RBSU, go to Network and select DNS/DHCP option from there.
4. Press Space bar and disable the DHCP as we are going to set a static IP for iLO.
5. Under Network menu, select NIC and TCP/IP settings.
6. Now enter an IP address and Subnet Mask for your iLO (Example: 16.180.237.8)

To Save the settings, please press F10 key.
10. Go to File menu and select Exit to close the iLO Configuration window.

 

for more info please refer to server User guide : http://www.storagenetworks.com/documents/manuals/dl380p-gen8-manual.pdf

 

hope this helps,

 

how to say thanks...Click on Kudo Star!

 

cheers!

Ali

I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
Jimmy Vance
HPE Pro

Re: Setup IPMI on HP DL 380 G8

iLO4 fencing is setup using fence_ipmilan. This document shows how to configure the fence

 

How to Configure Red Hat Cluster Services Fencing with iLO 3

http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&dlc=en&docname=c03138211




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Aldih
Occasional Contributor

Re: Setup IPMI on HP DL 380 G8

Hi,

need help again, i have followed the instruction to enable IPMI TCP/IP via BIOS and still not working when i want to connect to IPMI on another machine.

Here's the capture.
==============================================================================
[root@node1 ~]# ipmitool lan print 2
Set in Progress         : Set Complete
Auth Type Support       :
IP Address Source       : Static Address
IP Address              : 192.168.1.1
Subnet Mask             : 255.255.255.0
MAC Address             : 28:92:4a:36:71:82
BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Disabled
Default Gateway IP      : 192.168.1.2
802.1q VLAN ID          : Disabled
802.1q VLAN Priority    : 0
Cipher Suite Priv Max   : Not Available
[root@node1 ~]#

[root@node1 ~]# ping 192.168.1.2
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
64 bytes from 192.168.1.2: icmp_seq=1 ttl=254 time=21.9 ms
64 bytes from 192.168.1.2: icmp_seq=2 ttl=254 time=4.41 ms
64 bytes from 192.168.1.2: icmp_seq=3 ttl=254 time=6.97 ms

[root@node1 ~]# ipmitool -I lan -U admin -P P@ssw0rd -H 192.168.1.2 chassis status
Error: Unable to establish LAN session
Error sending Chassis Status command
[root@node1 ~]#

==========================================================================

however, when i execute " ipmitool -I open -U admin -P P@ssw0rd -H 192.168.1.2 chassis status", that i used interface "open", it shows the output.

Any ideas, maybe how to enable interface "lan" on ipmitool.

By the way, i have tested the fence and it shows "fence node2 failed", i think this error could be related with unable communication ipmi using interface lan, correct if i'm wrong :).

Thanks in Advance.

Regards,

Aldi

Jimmy Vance
HPE Pro

Re: Setup IPMI on HP DL 380 G8

is the port open in iptables?




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Aldih
Occasional Contributor

Re: Setup IPMI on HP DL 380 G8

I have already turned off the firewall, i did something like :

 

# setup --> remove the asterisk (*) on the Enabled.

# service iptables stop

# chkconfig iptables off

 

i think the firewall should be turn off already.

 

 

Note :

Physically, i did connect the LAN RJ-45 cable (Straight-thru) from iLO's Port server node1 to iLO's Port server node2 with their own segment IP (like 192.168.1.1 at node 1 and 192.168.1.2 at node2) and when i ping each other from OS (rhel 6.3), it replied (worked). i assumed that the connectivity was no issue at all. so that i tried to remote ipmitool node 2 by using the command "ipmitool -H 192.168.1.2 -I open -U admin -P P@ssw0rd chassis power status" and it show the output. However when i used the flag option " -I lan", it didn't work.

 

did i missed some configuration ?

 

or Is this just related with HP iLO's License that my company didn't buy it ?

 

Thanks.

 

Regards,

Aldi

Jimmy Vance
HPE Pro

Re: Setup IPMI on HP DL 380 G8

The syntax should be:

 

ipmitool -H <hostname/IP> -I lanplus -U <username> -P <password> chassis power status

                                                             ^ just for clarity this is a capitol i, not a lower case l

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Aldih
Occasional Contributor

Re: Setup IPMI on HP DL 380 G8

Hi,

 

Still not working, here's i give you the screenshot.

 

may be some setting that i missed. :(

 

Regards,

Aldi

Jimmy Vance
HPE Pro

Re: Setup IPMI on HP DL 380 G8

Please go into the iLO web interface, under Administration - Access Settings, look under IPMI/DCMI and verify the checkbox is selected "Enable IPMI/DCMI over LAN on Port 623"

 



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Aldih
Occasional Contributor

Re: Setup IPMI on HP DL 380 G8

Hi Jimmy,
Is it possible to access iLO web interface without we buy the license of iLO?
Because i didn't setup the iLO yet.

Thanks,
Aldi
Jimmy Vance
HPE Pro

Re: Setup IPMI on HP DL 380 G8

Yes, you can access the iLO web Interface for administration and settings. The Advanced Pack license is only required for some of the advanced features of iLO




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Derek_Bannard
Occasional Visitor

Re: Setup IPMI on HP DL 380 G8

Your IP address and gateway are setup incorrectly.

 

Verify your gateway IP address, likely 192.168.1.1, and the IP's you want for the servers.

 

Would suggest using 192.168.1.10 and 192.168.1.11, but it really doesn't matter as long as you DO NOT use your gateway IP address as your server IP address as shown in your screenshot.

 

Make sure your router has an IP address of 192.168.1.1, if not, modify the below information with your routers IP address.

If you do not have a router and are creating a separate un-routable network, make sure you leave the gateway IP blank and have BROADCAST enabled on the switch you are connecting to. Won't work otherwise.

 

Server 1:

IP Address: 192.168.1.10

SUBNET: 255.255.255.0

Gateway: 192.168.1.1

 

Server 2:

IP Address: 192.168.1.11

SUBNET: 255.255.255.0

Gateway: 192.168.1.1