ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Slowing fans for Proliant 100-series

zilav
Occasional Advisor

Slowing fans for Proliant 100-series

Unlike other Proliant servers, 100-series don't have any drivers for controlling the fans, and they always run at the full speed, producing enormous noise.
The only way to slow them down is using IPMI, but there is no full documentation on IPMI programming for HP servers, only several pdf docs claiming that incorrect actions can damage your motherboard, and other horrors.
Unfortunately, my organization acquired dl160 g5 that was heard from rooms 100 meters away.
I've spent almost a month reading this forum, other forums, blogs, etc... and finally managed to fix this problem. That's why I decided to write a quick how-to guide for other frustrated proliant owners.

-= Step1 =-
As usual, upgrade your BIOS, iLO firmare and reset CMOS (there is a little button near battery on motherboard), perhaps this would help.

-= Step2 =-
Install IPMI driver.
In Windows 2008 it is installed by default, so continue reading to step 3.
In Windows 2003 you'll need to install it manually, refer here for details:
http://blogs.sun.com/pavelbures/entry/utilizing_ipmi_kcs_interface_in

-= Step 3 =-
Unpack the attached file in folder C:\IPMI
It contains:
ipmitool.exe and libeay32 - from Sun's ipmitool port for Windows http://www.sun.com/download/products.xml?id=46f1ff04
winserv.exe - free open-source utility for running apps as a services http://sw4me.com/wiki/Winserv
*.cmd files - read below.

You can use other path of you choice, but in this case modify *.cmd files and replace "C:\IPMI" with your path.
Also, if you've installed SUN ISM driver during step 2, replace "-I ms" with "-I ism".


-= Step 4 =-
Testing the IPMI driver.
Run test1.cmd, if everything is ok you'll see the info on you server. If the error about opening IPMI appears, go back to Step 2.

-= Step 5 =-
Trying to slow down the fans.
Run test2.cmd, after several seconds (5-10 sec) they should slow down, if not - well, thx for reading, I can't help you anymore.
In my case fans go from 8000+ rpm down to 3200 rpm.

-= Step 6 =-
Installing as a service.
Run install.cmd to create "BMCreset" service. Upon windows start up it will slow fans and exit.
Later, use uninstall.cmd to get rid of it if you don't need anymore.

-= Step 7 =-
Stress-test your server.
The negative part of slow fans is guess what... heat. Slowing achieved by resetting BMC (baseboard management controller or smth like that), which also turns off fan control, so they won't speed up even if your server is going to blow. That's why I STRONGLY recommend you to be careful and watch closely temperature sensors.
For example, my dl160g5 has only 2 sensors - near PCI bus and rear ambient showing 45C and 41C, and thats quite a lot. It is 2008 server with Xeon 2.8Ghz, 10GB RAM and 3 HDDs, used as a file server, domain controller, internet NAT gateway, NetFlow collector and terminal server for 1-2 users. Now working normally almost a week without freezes, hangs, BSODs and errors.

Anyway, use this guide at your own risk, and only if desperate.



20 REPLIES
KarloChacon
Honored Contributor

Re: Slowing fans for Proliant 100-series

interesting fix

thanks a lot
Didn't your momma teach you to say thanks!
JuanK_1
Advisor

Re: Slowing fans for Proliant 100-series

Zilay, thank you very much for taking the time to specify, step by step, this solution plan.

There are some other people with the same problem so I really thank you if you guys could let us know your results.

Regards;
AndyH-UK
Occasional Visitor

Re: Slowing fans for Proliant 100-series

Thanks for posting this.

Just tried it with my ML115 and it didn't work unfortunately. Is there a command reference for ipmitool?
zilav
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Here...
http://docs.sun.com/source/820-1120-19/WinIPMI.html
link at the bottom of page. Just don't forget to specify IPMI interface with -I switch ("ms" for Microsoft driver, "ims" for Sun driver).
zilav
Occasional Advisor

Re: Slowing fans for Proliant 100-series

...oops, sorry, "ism" for Sun driver :)
MarkusL
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Thank you very much!
This works...
MarkusL
Occasional Advisor

Re: Slowing fans for Proliant 100-series

As in "test2.cmd", this command sets the fan speed to "slow":

ipmitool.exe -I ms bmc reset warm

Do you know a command to set the fans to original speed again?

In SpeedFan 4.37 you are able to execute a program, when a temperature is reached.
So i hope to get the fans temperature-controlled this way.
ldarko
Occasional Visitor

Re: Slowing fans for Proliant 100-series

thank you for this post :)
there is a hope :)
I have HP DL160 G5 Proliant with Debian Lenny (testing)
My question is:
how use it ipmitool from Windows Xp Prof by the LAN
I enabled IPMI share NIC in the bios.
Maybe you know commands to slow down FANs by the Lan (from windows xp)
best regards
ldarko
Occasional Visitor

Re: Slowing fans for Proliant 100-series

ok I found commands for lan:
ipmitool -I lanplus -H host ... etc

only one problem:

how to reset fan to normall speed without reset computer :) ???
darek
lavajava
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Hi,

I've tried using this on Windows 2008 and just get the following:-

C:\IPMI>ipmitool.exe -I ms fru
FRU Device Description : Builtin FRU Device (ID 0)
Could not enumerate class object (80041003)
Device not present (No Response)

Could not enumerate class object (80041003)
Get Device ID command failed

Any ideas?

thanks,

Danny.
zilav
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Odd really...
Try to uninstall MS IPMI driver (in 2003 server its called "Hardware Management", dunno about 2008) and use the Sun's one instead.
lavajava
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Is it safe to install that driver on Windows 2008, it looks like it 2003 only?
lavajava
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Tried installing the Sun IPMI driver and it wouldn't load properly (2003 version).

Has anyone else got this solution working on 2008 x64?
zilav
Occasional Advisor

Re: Slowing fans for Proliant 100-series

How about trying to access IPMI across the LAN (from Win 2003 machine) as ldarko mentioned earlier? Just to check if this can work for you at all.
lavajava
Occasional Advisor

Re: Slowing fans for Proliant 100-series

If the local IPMI tool can't access the driver / hardware, surely accessing via the lan will be the same?

lavajava
Occasional Advisor

Re: Slowing fans for Proliant 100-series

I've enabled the IPMI lan in the bios, but when I try and connect using IPMI tool it asks for a password?

Where / how is this set?

Whats the full command line to use via the LAN?

many thanks,

Danny.
Carlos LLinas
Occasional Visitor

Re: Slowing fans for Proliant 100-series

How I get the files .cmd

I try with command
ipmitool.exe -I ms bmc reset warm or cold

and ever the fans rise your speed to 14000rpm
ricom1
Occasional Visitor

Re: Slowing fans for Proliant 100-series

We use HP's DL180 G5 servers and experienced the same loud fan noise after updating the BIOS system ROM. The solution is to 1st update the Firmware - Management. You need to get to latest Lights-Out rev which is 3.1.1. During system boot DOS commands will display which rev. you have installed.

HP's lates BIOS in conjunction to the older Firmware management update appears to cause a firmware mismatch causing the fans to race at high RPM's.

If the latest Firmware Management rev. does not install, Go to the 'revision history' tab and load the oldest rev. 1st. Download the newer rev. until you install the newest rev. 'last'. Upon sys. boot, the fans will quiet. Solution presented by http://www.shopricom.com/ who runs HP's DL180 G5 servers in our datacenter.
MarkusL
Occasional Advisor

Re: Slowing fans for Proliant 100-series

Hi,
since this solved my problem for 1.5 years.
Unfortunatly after a Firmware Update it does not work again.
Any ideas?

thank you
MarkusL
Occasional Advisor

Re: Slowing fans for Proliant 100-series

...ok, i changed to the old firmware again. This solved my problem.
Don't change a running system :-)