HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

SmartStart 8.30 x64 does not work with W2008R2 ROK ML350G5

 
ENettekoven
Occasional Contributor

SmartStart 8.30 x64 does not work with W2008R2 ROK ML350G5

Unfortunately the installation of Windows 2008 R2 x64 ROK (HP Branded) using the SmartStart 8.30 x64 fails.

After the copy OS files from the DVD is finished the server will reboot and boot into a PE environment. From there the installation fails with the error:
"Windows could not parse or process unattend answer file [c:\autounattend.xml] for pass [windowsPE]. The answer file is invalid"


* Every hardware component is up-to-date (last checked for updates on 17th of Februari 2010).
* I do not use any "weird" characters in servernames or whatsoever during setup.
* All hardware is detected correctly by the smartstart CD.

Any suggestions or upcoming fixes in the near future? (except the obvious like install OS first then apply the PSP)
1 REPLY
ENettekoven
Occasional Contributor

Re: SmartStart 8.30 x64 does not work with W2008R2 ROK ML350G5

Found a solution!

First I have to make clear I did not, I repeat, dit NOT have to fill in a product key during the setup phase of smartStart. There was no space to fill it anywhere.

So it clearly appears that SmartStart or the ROK CD inputs its own Product Key, but appended (here is the culprit) with a space. Removing this space solves the error.

To make it clear (removed original key). This is how it is saved in the xml file:
XXXX-YYYYY-ZZZZZ-AAAAA-BBBBB

and:
XXXX-YYYYY-ZZZZZ-AAAAA-BBBBB

Notice the space before and before .

Futhermore you will not see this space if you open the .xml file using a browser. You will need to open the autounattend.xml using notepad or using Windows System Image Manager (available in the WAIK). If you use the latter and associate a .clg file with it, validation will also fail on this space. It will also generate another error which you'll need to ignore.

Removing the spaces using notepad is the preferred method. Especially because you can run notepad within the WinPE to edit the autounattend.xml directly on the server.

So the step-by-step for this workaround:
* Install the server using smartstart

* As soon as you get this error, run notepad and open c:\autounattend.xml.

* Remove the spaces behind the product keys, and save the changes to the .xml file. Becareful not to save the changes to a autounattend.xml.txt => just use "save" instead of "save as"!

* run c:\hpssbem.exe

* installation will continu

Until HP figures out how to remove this space or gives you the option to enter your own product key (WITHOUT a space at the end), you will need to use this workaround. I hope HP will fix this in a following SmartStart release