ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

 

Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

I have installed a pci graphics card into a DL740. Fresh install , all other devices fine in device manager. Please could I ask advice as I have gone through the forum / technical releases / drivers. All to no avail.

The card is functioning, in so much as I am able to use it as a display device however, when I try to install drivers or examine it in devices under windows , it states that the device cannot start as it lacks resources.

Please can I ask for help as I am at wit's end trying to find a solution.

5 REPLIES
marcus1234
Honored Contributor

Re: Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

marcus1234
Honored Contributor

Re: Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

to clarify

Code 12
This device cannot find enough free resources that it can use. If you want to use this device, you will need to disable one of the other devices on this system. (Code 12)
Cause

This error can occur if two devices that are installed on your computer have been assigned the same I/O ports, the same interrupt, or the same Direct Memory Access channel (either by the BIOS, the operating system, or both). This error message can also appear if the BIOS did not allocate enough resources to the device.

Re: Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

Thank you for your reply.

I have established that the error is not an o/s based but bios based problem. I have installed both Windows 2003 and Linux onto the proliant server and both come up with the same error.

Please could I find some help with determining how I can install an additional card and correctly allocate the relevent resources.
Jimmy Vance
HPE Pro

Re: Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

That system went end-of-life in 2006. Not sure if this option was in the System ROMS back then but you can look but look under

Advanced Options - Option ROM Loading Sequence

and change it to

Load Option Card Devices First




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   

Re: Still having "code 12" problem after installing pci card into DL740. Fresh build advice needed pls.

Nope not an option to specify loading add-in cards prior to onboard.

I have disabled the onboard card using the dip switches on the main board.

I know that most of the time most people would not think to add a better card to the server as its well, a server but aside from graphics performance this machine is perfect for my needs, it sits under the stairs linked up to an amp through a digital sound card ( external usb ), that works fine, linked up to a 42" screen and my little home music room is complete. The only thing it cannot do is play videos, the 8mb rage simply is not designed for that.

I would value any ideas such as downgrading the card I am putting in to a matrox ( was thinking maybe the card I am putting in would be too greedy with resources?), has anyone had any similair experience??, maybe switch to an ATI? given that the on-0board is an ATI perhaps I should try an older ATI 32mb card?

Any help would be appreaciated as this is turning into a white elephant my other half is berating me over, not least because of the time I am spending trying to fix it.

Yours Hopefully.