ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Strange boot problem

Ed Luna
Occasional Contributor

Strange boot problem

I'll be as brief as possible.

ML350 G4 Server with a Smart Array 641, 3 drives setup as 3 logical... The server is a few years old.
I Was running Microsoft 2000 Server until 6 months ago when I upgraded to Windows 2008 Server Standard. I left the original OS in place and setup a dual boot.

During the original install of 2008 I needed to use the F6 option to install drivers for the Array as I didn't want to use Smart Start and risk data loss. The install of 2008 went fine and all has been fine ever since.

Just this morning I needed to re-boot the server and it wouldn't boot. It gave me a message about missing file or corrupt file and said to use the repair my computer option by booting from the 2008 install CD and selecting "repair". I tried doing that but it prompted me for the driver (I assume it needed the Disk driver again) so I used the same diskette (holy crap) that I had used when I installed the OS (using F6) but this time it told me that the drivers weren't found. I tried several variations of drivers... some freshly downloaded and some from the Smart Start CD but nothing would work.

Desperation set in as I had an entire company sitting on its hands waiting for me to bring the server up so I reluctantly decided to boot to the original OS (Windows 2000) and let them work using the old OS for today and I would fix the server over the weekend. No joy... many messages about broken trusts etc so I abandoned that idea and went back to trying to get the "repair my computer" function to work. Again... no joy.

I decided to try the old OS again and rebooted the machine (for about the 10th time today) but prior to the OS selection screen being displayed I was called away and by the time I got back the machine had booted to the new OS (Win 2008 server is the default) and everything was working fine. Good grief!

I can't just shrug my shoulders and say "Oh well". I need to know why the machine decided to load properly this time, after repeated attempts earlier had all failed. Is it possible that my booting into the old OS somehow restored some files needed for boot? I'm at a loss to explain.

Any ideas?
Thanks
4 REPLIES
Michael A. McKenney
Respected Contributor

Re: Strange boot problem

What file was missing NTLDR? Document all boot errors. You don't want to go back to 2000 after putting in 2008. You can corrupt Active Directory Services. I hope this server is not your only Active Directory server.

Do you have a full backup of all your data? What probably happened was the boot sector data was lost. Can you boot to safe mode with command prompt or safe mode with networking? If yes, run fixmbr and fixboot from 2008.
Ed Luna
Occasional Contributor

Re: Strange boot problem

This is not my only active directory server... it is a member server in a Microsoft Small Business Server network.

Being that the member server is dual-boot do you still think there is a risk of Active Directory problems? I'm not sure.

If it happens again I'll pay more attention to what file it says is corrupted but I am certain it wasn't NTLDR.

I have a full backup using the built-in Windows 2008 Server Backup facility.

Can you think of any reason why I couldn't run the "repair" function? What "drivers" would you assume it is asking for? I assumed it needed the Smart Array 641 drivers but it wouldn't accept the same drivers I used that worked fine when I originally installed Windows 2003 Server.

Thanks for your input.
Ali
HPE Pro

Re: Strange boot problem

Hi Ed Luna,

Dual boot in enterprise environment is not recommended.

Possible this behavior is due to two different Smart array controller drivers... and latest driver which for windows 2008 has taken the priority.

smart array controller driver for windows 2003 and 2008 is same but windows 2000 uses different driver.

thanks,
Aftab
I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
Michael A. McKenney
Respected Contributor

Re: Strange boot problem

The boot partition of 2000 and 2008 are vastly different. It could be corrupted and cause it not to boot. You could try a fixmbr and fixboot to repair it.

Never shrug your shoulders when a server is down. They can find someone else to fix it when your on your way to the unemployment office.

Dual booting a production server is not supported by Microsoft or HP. You will probably want to remove both OS and all partitions and reinstall 2008 from scratch to fix it. I hope your backup is complete.