ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Suppt Pack 8.73: SMH & Diags can see array, but Diagnose tool can't

chrism02
Occasional Visitor

Suppt Pack 8.73: SMH & Diags can see array, but Diagnose tool can't

Hi Guys,

 

Its the HP std tools in the ProLiant Support Pack 8.73 for RHEL5.

 

Specifically HP Insight Diagnostics can see HW Disk Array, as can HP System Management Homepage/Storage sub-page, but when you run the Diagnose option in the HP Diags tool, it says

 

Logical Volume 0, Controller Slot 0 Bus 0        Device not found CISS0v0
Specified device is not found or check for the proper device connectivity.            Errorcode= 903003

 

Logical Volume 1, Controller Slot 0 Bus 0        Device not found CISS0v1

Specified device is not found or check for the proper device connectivity.            Errocode=903003

 

Any ideas?

More info avail on request (its a P400 array)

 

Cheers

Chris

4 REPLIES
Johan Guldmyr
Honored Contributor

Re: Suppt Pack 8.73: SMH & Diags can see array, but Diagnose tool can't

Hey, for Windows re-installing the software solves quite a few problems. Unsure for linux though. Is CISS0v0 the actual name of the device on your system? Is it in an HP server?

There is also the HP ADU tool which can diagnose/provide lots of information the raid card.
chrism02
Occasional Visitor

Re: Suppt Pack 8.73: SMH & Diags can see array, but Diagnose tool can't

Hi,

 

I've only just  installed (updated) the HP Tools and it's Linux :)

Machine is HP ProLiant DL380 G5.

It's a Smart Array P400, shows up as /dev/cciss/c0d0, /dev/cciss/c0d1 using fdisk.

 

Let me know if you need more info; its the first time I've been involved with this stuff (HP Tools)

 

Speaking of which, any good links/cmds to use the ADU?

 

Does this help ?

hpacucli ctrl all show config

Smart Array P400 in Slot 1                (sn: PAFGK0P9SX10TW)

   array A (SAS, Unused Space: 0 MB)


      logicaldrive 1 (68.3 GB, RAID 1, OK)

      physicaldrive 2I:1:1 (port 2I:box 1:bay 1, SAS, 72 GB, OK)
      physicaldrive 2I:1:2 (port 2I:box 1:bay 2, SAS, 72 GB, OK)

   array B (SAS, Unused Space: 0 MB)


      logicaldrive 2 (838.1 GB, RAID 5, OK)

      physicaldrive 1I:1:5 (port 1I:box 1:bay 5, SAS, 300 GB, OK)
      physicaldrive 1I:1:6 (port 1I:box 1:bay 6, SAS, 300 GB, OK)
      physicaldrive 2I:1:3 (port 2I:box 1:bay 3, SAS, 300 GB, OK)
      physicaldrive 2I:1:4 (port 2I:box 1:bay 4, SAS, 300 GB, OK)

 

Like i said, most of the tools can see & report it correctly, its just the 'Diagnose' tab/cmd that has issues...

 

Cheers

Chris

 

Johan Guldmyr
Honored Contributor

Re: Suppt Pack 8.73: SMH & Diags can see array, but Diagnose tool can't

Hey, as far as I know ADU only outputs a .txt, html or .xml file that you can view however you want it.

 

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=3219233&swItem=MTX-ecf710836ef24a958c672a8ac6&prodNameId=3288112&swEnvOID=4004&swLang=8&taskId=135&mode=4&idx=1

 

Tried those commands for hpdiags? Or maybe through those files you can find out which device it's actually trying to access, why and if you can change it :p

 

Is it OK to make a symbolic link between your devices to this CISSv0 that it asks for? Or could that be bad?

chrism02
Occasional Visitor

Re: Suppt Pack 8.73: SMH & Diags can see array, but Diagnose tool can't

thx for that, but the mystery deepens:

 

 rpm -qa|grep diag =>
hpdiags-8.7.2-7

 

however, in /etc/init.d the only HP stuff I have is

 

hp-asrd

hp-health

hp-ilo

hplip

hpsmhd

hp-snmp-agents

hpvca

 

 

checking rpm for all HP:

 

hpdiags-8.7.2-7
hp-pel-1.0.2-1.rhel5
hponcfg-3.1.1-0
hp-snmp-agents-8.7.0.23-17
hplip-1.6.7-4.1.el5
hp-OpenIPMI-7.9.0-110.rhel5
hpacucli-8.70-8.0
hp-ilo-8.5.0-1.rhel5
hp-smh-templates-8.7.0.10-10
hpijs-1.6.7-4.1.el5
hp-health-8.7.0.22-20
hpsmh-6.3.0-22
hpvca-6.3.0-8

Open to suggestions ...

 

Cheers

Chris