ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Sysprep on a ML370/DL380 (G3)

 
Jon Reynolds
Occasional Visitor

Sysprep on a ML370/DL380 (G3)

Built a ML380 as win2k server but I'm having problems on restoring a sysprep'ed image on to a DL380 (both G3).

The DL380 blue screens with an Inaccessable Boot Device error. This has to be a problem with the array controller but the 5i in the DL uses the same driver as the ML's. I've attached teh sysprep.inf.

Can anyone shed any light on it as we've tried including removing and including the driver references in the mass storage section of the sysprep.inf and still the same blue screen error.
5 REPLIES 5
Martin Forster_1
Frequent Advisor

Re: Sysprep on a ML370/DL380 (G3)

i suggest that they have differnt PnP IDs,

That this driver to Device ID (PNP Id) must fail.

Greetings.
Jon Reynolds
Occasional Visitor

Re: Sysprep on a ML370/DL380 (G3)

Thanks, I'll give it a try.
Martin Forster_1
Frequent Advisor

Re: Sysprep on a ML370/DL380 (G3)

damn,
i should really reread my posts.

The 2nd sentence means should mean:

Than this device ID(PnP ID) to driver mapping must fail.

Greetings
Jon Reynolds
Occasional Visitor

Re: Sysprep on a ML370/DL380 (G3)

Thanks Martin,
Yes they do. The second half of the PnP ID is different. I've decided to load .NET Server and use sysprep from there as that version compiles the inf file for you so I'm sure we have the right one. I'll keep this open so I can post the values when I've done it.

Cheers for the fix.
Highlighted
Jon Reynolds
Occasional Visitor

Re: Sysprep on a ML370/DL380 (G3)

Heres the solution:

Its a problem with the Device ID's found in the oemsetup.inf that comes with the driver. I pulled them out of the registry on a smartstart install.

put these in your SysprepMassStorage section of sysprep.inf:

[SysprepMassStorage]
pci\ven_0e11&dev_b178&subsys_40820e11=c:\cpqsystem\pnpdrvs\cpqcissm.inf
pci\ven_0e11&dev_b178&subsys_40800e11=c:\cpqsystem\pnpdrvs\cpqcissm.inf
pci\ven_9005&dev_00c0&subsys_f6200e11=c:\cpqsystem\pnpdrvs\adpu160m.inf

The first line is for the DL380 G3 and the next for the ML370 G3.

Works fine.