ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble with RAID1

 
AFyodorov
Advisor

Trouble with RAID1

Hello all.

We have a DL380 G4 that has three RAID1 volumes.

The first RAID1 (where the OS lives) consists of two 146GB 15K RPM disks.

We wanted to expand the capacity of this RAID1 volume by replacing one of the disks with a 300GB 15K RPM disk, letting the RAID rebuild, then replacing the other 146GB disk with a 300GB disk and letting the RAID rebuild.

So we pulled out the drive sith ID 1 and replaced it with a 300GB drive. RAID1 started rebuilding and failed. So we pulled out the 300GB drive and put in the original 146GB drive - no reaction, the server doesn't even seem to notice that the drive was inserted. Actually at this point, it doesn't notice whether we insert a new 300GB drive or the old 146GB drive.

We tried to reboot. During boot, the server says that drive with ID 1 has failed and should be replaced. But again, it doesn't care when we insert a drive. We tried the old 146GB drive, a new 300GB drive, and yet another new 300GB drive.

Has SmartArray 6i gone coo-coo on ue?

We spoke to HP support, they think that SCSI backplane is bad and are sending us a new SCSI backplane. Fine. I just think that there is something wrong with the controller's logic.

Oh we also tried to upgrade firmware on the Raid controller. Didn't help.

Is there anything we can do to make the controller see that a new drive was inserted? Thanks!
1 REPLY
e4services
Honored Contributor

Re: Trouble with RAID1

Well first, I would bacl up this problem volume. Second, at this point you will have no choice but to delete the RAID set and re-configure it with the 300GB drives, restoring from the backup. And yes, I thik the 6i has gone Coocoo, may be a configuration error or something.
Hot Swap Hard Drives