ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Troubles with firmware update

infofarmer
Occasional Visitor

Troubles with firmware update

I have a DL145 G2 SATA server. It doesn't have a floppy drive, but it has a cd-rom.

I don't have linux or windoze installed, in fact i don't have any OS installed just yet. The server is a bit buggy. For example, when you access the BIOS section concerning console redirection - then just leave it without changing any options, the console redirection gets enabled all of a sudden. And if you don't have a serial console handy (or if you don't remember the right settings, cuz industry standard 9600-8N1 don't work), you'll have to clear CMOS by opening the case and switching an undocumented DIP switch.

So I decided to update BIOS and LOM firmware.

As I said, I don't have a floppy drive and I don't have one in my notebook. It's also purely coincidental that I have windows installed on my notebook - so I was a bit puzzled when I saw *exe files (under Linux section yet!) Well I downloaded the files, installed virtual floppy drive on my notebook, made binary images and tried to burn them (in multiple-image and in single-image modes). The server refused to boot saying something like "Non-system disk".

Okay, it happens.

I saw a section in the BIOS Setup, where you can boot from virtual floppy. I set up a tftp server, tested it from the subnet, but I didn't really know what to write in as the address path. So I just wrote unqualified image name (like 123.img) and verified that the tftp server sent it right. But the hp server timed out and refused to boot from it. I looked for documentation, but all I could find was not relevant.

Big deal, let's look for some other options.

Bingo, the Firmware CD. From my point of view, it's the best approach to firmware updates. Alas my $xxxx server is a bit too cheap for its firmware to be included on the CD. I understand that. (And BTW the 390Mb file is throttled down to 31.1Kb/sec, which results in 3.5 hours of download time [Lucky me, I read the contents before starting the download]).

Well, there's the usb option. But the server is too cheap to be even mentioned in the support table.

Then again, you can update firmware from LOM. Sorry, in the next version (I have 1.00 installed).

Guys, what's wrong with HP? Or, more importantly, how the heck do I update.

Thanks,
Andrew P.
4 REPLIES
Prashant (I am Back)
Honored Contributor

Re: Troubles with firmware update

Hi,

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00218060/c00218060.pdf

What i want to confirm is have you booted with usb floppy
YES/NO
I know compatibility matrix is not talking about it
-----------------------------------------
BIOS support for USB devices The system BIOS (ROM) requires additional functionality to support initializing and booting a USB drive key, as well as any other USB device. This is termed â legacy USB supportâ by HP. Basically, the system BIOS will attempt to boot the drive key as a mass storage device, thereby enabling the full capacity of the device. However, most drive key devices do not come properly formatted, meaning there is nothing for the system to boot. This is similar to attempting to boot a blank floppy diskette. The system BIOS would support initializing and booting that device, but no boot files are available to execute. The HP drive key Smart Component lands bootable files that the system BIOS can execute. This means that to boot a drive key, the server requires system BIOS support, as well as drive key support. The system BIOS will handle booting and executing files from the drive key until an operating system loads and the USB driver is loaded. At this point, the system BIOS is no longer involved in the support for the device.
--------------------------------------
Sorry even i need to check any other option for this server. Where in same kind of senario once i used nero to creat a bootable cd then copy the content on that and then ran on server.
In nero you have option to do so.
TRy it

I know my post in this is not much helpfull
Bec server is considered low end so less support for the same.

Prashant S.
Nothing is impossible
infofarmer
Occasional Visitor

Re: Troubles with firmware update

I tried to boot from a flash drive today - with no success. It wasn't even detected at boot, so I think the USB Legacy support on this box is limited to keyboard/mouse.

So, are there any other ways to go?

BTW, I managed to get the console redirection working, not that it helps in any way.
Dmitry Morozovsky
Occasional Contributor

Re: Troubles with firmware update

I also end up with IBM (actually Toshiba/Teac) USB Floppy: neither CD nor USB-flash boot work for me.

We bought IBM 27L4226 drive for $20 or so...
infofarmer
Occasional Visitor

Re: Troubles with firmware update

I've just solved my problem by customizing ubcd (http://ubcd.sf.net) with floppy images. Some day I may even write a how-to.

The console redirection bug did not seem to go away, though :-(