ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to disable Press F1 key at bootup

JLeslie
Frequent Advisor

Trying to disable Press F1 key at bootup

I have an ML530 G1 that has a piece of hardware not working correctly and so when I reboot the server it stops and asks to have the F1 key pressed to continue booting. I understand why it does that and for the sake of this thread, let's leave out talk about replacing the bad hardware.

 

I just want to disable that F1 prompt. The server was rebuilt without a utilities partition so pressing F10 doesn't do anything. I have booted from 2 SmartStart CDs as I've seen elsewhere that that is how to get to the setting to change it. I've tried ver 7.70 and ver 5.5 of SmartStart. The newer one is probably too new a version and it only displays info and gives no opportunity to change anything. Ver 5.5 does let you change things, but I went all through it multiple times, multiple boots, and didn't see anything anywhere in it that would let me disable this F1 prompt.

 

So just how can I disable this F1 prompt on my ML530 G1?

 

Jonathan

20 REPLIES
Torsten.
Acclaimed Contributor

Re: Trying to disable Press F1 key at bootup

AFAIR this was *anywhere* in RBSU.

 

I'll try to find more ...


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Trying to disable Press F1 key at bootup

rbsu.jpg

 

Behind the top window, called "POST F1 Prompt"


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Trying to disable Press F1 key at bootup

rbsu1.jpg

 

better picture, taken from the old RBSU Manual (HP ROM-Based Setup Utility User Guide )

 

 

Set it from enabled to delayed, the system will continue after 20 seconds.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

Just how do you get to that screen? You can't get directly into the BIOS like you can on a PC and the SmartStart CDs I've tried certainly don't show anything like what you showed.

 

Jonathan

Torsten.
Acclaimed Contributor

Re: Trying to disable Press F1 key at bootup

Did you try F9 to enter the BIOS (RBSU)?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Trying to disable Press F1 key at bootup

Such an old box!!!

Try if this helps:

http://h10010.www1.hp.com/ewfrf/wc/document?docname=bph07110&lc=en&cc=us&dlc=en&product=316544#N756

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3285469&prodTypeId=15351&prodSeriesId=341571&swLang=8&taskId=135&swEnvOID=181#7832

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=341571&prodNameId=3285469&swEnvOID=181&swLang=8&mode=2&taskId=135&swItem=MTX-UNITY-I13227

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

As I stated not very clearly in my original message, I don't have the RBSU partition on this server, it was rebuilt from scratch without a SmartStart CD. So I can't go that route. Thanks anyway.

Torsten.
Acclaimed Contributor

Re: Trying to disable Press F1 key at bootup

The last link points to floppy disk images, maybe this can help?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

I'll let you know. It's been so long since I used a floppy on it that I don't even know if the floppy drive still works. I had to replace the CD drive last year.

JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

The first link isn't any help really as it is geared more towards PCs and the ML530 is of a design unlike PCs when it comes to things like getting to the BIOS.

 

The second link is one I've been to many times and have a shortcut to on the desktop. But I haven't found anything on that page to help with this case. I had to google for smartstart cd for an ml530 and then got the link at HP for the download for 5.5 which as I said didn't help.

 

So I'll try the third link for the floppies and see if the floppy drive still works and if the software gets me into the BIOS. I really thought that there would be software on a CD that would do it and I especially thought that was one of the purposes of the SmartStart CD.

gregersenj
Honored Contributor

Re: Trying to disable Press F1 key at bootup

You must use advanced mode in the setup utility.

 

From the smart start CD open the setup utility.

At the first screen in the setup utility hit CTRL+A

 

That will give you more selections, including disable F1 prompt.

 

BR

/jag

gregersenj
Honored Contributor

Re: Trying to disable Press F1 key at bootup

By the way, CTRL+A also work in the RBSU.
/jag
JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

I was completely unaware of that option. I didn't see anything on that screen in SmartStart that said to press CTRL+A for more options. I'll try that the next chance I get and let you know how it goes.
JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

I wish the RBSU was present but that's now how the server was setup so I'm stuck with the CD.
gregersenj
Honored Contributor

Re: Trying to disable Press F1 key at bootup

True, there's nothing telling you that you can press CTRL+A. But it's there's.

 

Yes the RBSU wasn't introduced untill G2 or G3.

There's pros and cons to both solutions.

Actually I like the old system partition :)

 

And now with the Gen8 servers the system partition is back, its now called Intelligent Provisioning, and residing on an internal flash disk.

 

BR

/jag

JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

Tried it today and no-go. Tried CTRL-A at several screens and it didn't do anything. This was with SS v5.5. There was an F7 for Advanced Options which I went all through before but I went through it again and there's nothing about disabling F1 or anything looking like it. I've attached a screenshot showing the first screen after the splashscreen. The first utility which is highlighted is the one I selected as it seems to me to be the only one that would have anything to do with what I'm trying to do. At this screen I tried CTRL-A and then once I went into the selected utility I tried it again as well as several sub-screens within the utility.

 

I also tried it with SS v7.7, pressing CTRL-A at several screens but that didn't do anything.

 

I tried booting from the floppies I created (which read just fine on more than one PC) but it couldn't read it so the floppy drive in the server must be bad. Ugh.

 

So I'm still at square one. Pressing CTRL-A in two versions of SmartStart does absolutely nothing. I don't know why HP designed such as screwy system rather than letting you press something during the POST like you can for array management, Lights-Out management, etc. Noooo, they had to make accessing the BIOS like trying to break into Fort Knox.

 

gregersenj
Honored Contributor

Re: Trying to disable Press F1 key at bootup

System Configuration Utility is the correct utility to use.

 

Once you get into the first screen in the SCU you hit CTRL+A, and then you select the system setup (Can't remember wahts it called).

I have used it my self long time ago, to change the F1 prompt behaviour.

So try again.

And if you want to try with a SS different from 5.5, use an older SS.

 

BR

/jag

JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

I did press Ctrl-A when I first got into the SCU. It did absolutely nothing.

JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

Can anyone direct me to where I can find SmartStart 5.3? I have googled it to death and can only find old posts of people with 5.3 wanting a newer version. Version 5.5 and above are all I can find to download and none of those versions will work. I can boot into them (though not 8.7 as it says it wants an x86 or x64 and what I have is an i686). So if anyone knows where I can download 5.3, I'd be more than willing to try it.

 

JL

JLeslie
Frequent Advisor

Re: Trying to disable Press F1 key at bootup

Here's what I get booting into SmartStart 5.5. They're in sequence. I don't know why I didn't take one more screenshot after choosing the -second- option in the 3rd pic.. I press Ctrl+A at each of these, including the screen I get after choosing the second option in the 3rd pic and nothing happens. Sorry for the flash glare.