ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

SOLVED
Go to solution
stardotstar_1
Occasional Contributor

Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

Hi,

This is my second DL360 - my other is a G4 and with the G5 I elected to go with the full 6 disk configuration.

I have 6 2.5" 72G disks and the system will only "see" the bottom row of 4...

I checked that there is the sas cable from the second sas backplane port (inside one) a black shielded cable running back to the p400i where it is plugged into the rear connector. (This is how it came configured - is that right or do I need to connect via the front connector on the p400i/backplane adapter nearer the left side of the server?)

The top two disks are not detected at all, nor do they light blue, orange or green at all. They work in the lower drive bays so the disks appear ok. They are not detected at all in the smart array config utility.

When I configured the lower row of 4 disks I found that I could make my RAID 1 + 0 amounting to one logical disk of 4 physical at approx 140G realestate. This configured and saved ok - then I installed Debian Stable 5.0 base system which saw the disk array as a single logical drive and installed fine - grub and all...

Then on reboot the system hangs at
Attempting to Boot From CD-ROM
Attempting to Boot From Hard Drive (C:)

All four lower row drives are blinking green.

I would appreciate any insight provided. I am searching and re-searching the resources here and on the web as well.

TIA
\\'
5 REPLIES
Oleg Mochkin
Trusted Contributor
Solution

Re: Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

Hi, it seems you have hardware problem. Check second SAS-cable - see Maintenance and Service Guide, HP Smart Array P400i Controller cabling, page 64 http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c00710376/c00710376.pdf Try to swap first and second cables. If cables OK, P400i second port is failed, call to HP tech support.
BR, Oleg.
stardotstar_1
Occasional Contributor

Re: Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

Invaluable Oleg, thank you.

I note that I only have a single cable running from that top backplane and clearly the diagram you point to in that documentation suggests I need two. I asked the supplier to ensure that all additional cabling was supplied and have subsequently asked them to supply it or confirm that it is not needed.

Without such a cable I cannot troubleshoot as you suggest but I am very grateful for the advice.

I am reading elsewhere that grub when installed on the smartarray needs to have the smart array in the boot order before the cdrom to work so I am investigating my second issue on that basis in the mean time.

Thanks again.
Will
Oleg Mochkin
Trusted Contributor

Re: Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

OK, look at QuickSpec http://h18004.www1.hp.com/products/quickspecs/12476_div/12476_div.html - "NOTE: The Smart Array P400i Controller can support a maximum of 6 hard drives. To support drives 5 and 6, the optional HP Mini SAS 4i 13.4 inch/0.35 m cable is required (PN 399546-B21)"
Jimmy Vance
HPE Pro

Re: Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

On your GRUB comment. The boot order doesn't matter. It will try to boot in the order you specify, you can have NIC and CDROM, before the hard disk, if the system doesn't PXE boot, and there is not a bootable CD in the ROM drive, then it will fall through to the hard disk and boot GRUB.

maybe GRUB didn't set itself up correctly.

Boot into rescue mode, mount and chroot to the hard disk and do the following to setup grub correctly.

This is assuming your disk is /dev/cciss/c0d0 which is what the smart array normally is.

/sbin/grub

when grub starts enter the following

device (hd0) /dev/cciss/c0d0
root (hd0,0)
setup (hd0)
quit




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
stardotstar_1
Occasional Contributor

Re: Two questions on DL360G5 p400i 6 disks - sees 4 (lower row only) and then won't boot with Debian

Thanks Jimmy, that is good advice, I will certainly take this approach. I have not pursued that just now since I have been distracted and need to switch the existing cable back on the P400i. I will indeed try to reinstall grub on the array from a rescue shell session at next possible moment.
I am not experienced with these raid arrays.