HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Ubuntu 16.04LTS on DL20Gen9

 
vovanj7
Occasional Visitor

Ubuntu 16.04LTS on DL20Gen9

Hi all!

I have strange behavior on my DL 20 Gen9 server with installed Ubuntu 16.04.3 LTS

I have disabled B140i and enabled AHCI Legacy mode and successfully install OS

When I try to edit the boot parameters( throught ILO), I can enter a small number of characters and after that the system freezes and does not react to clicking.

When I try edit grub parameters via text editor inside OS  (throught ILO) OS doesn't freeze

I updated all firmware to the latest version 

https://certification.ubuntu.com/hardware/201605-22006/

my CPU is intel Pentium G4400, 16Gb RAM, and 1 Tb HDD

Can somebody tells me why I can't  edit grub parameters?

3 REPLIES
MarcinWeg
HPE Pro

Re: Ubuntu 16.04LTS on DL20Gen9

Hello

Sorry for delay in response, are we able to work on your problem with boot order or you have managed to fix it;
If problem persist please give me some more information:
- please generate AHS log from iLO4 interface;
- please run cfg2html script available at ftp;
- please add some screenshots from place you receive error and from place where it works fine;
- is the problem from beggining of installation on server or it works fine earlier;
- how do you recover from problematic situation;
- please upload logs at ftp server
SFTP Access : sftp -o Port=2222 ffd55233@ftp.ext.hpe.com
sftp -P 2222 ffd55233@ftp.ext.hpe.com
HTTPS Access: https://ftp.ext.hpe.com/hprc
FTP Access : ftp://ffd55233:G8dv.IV5@ftp.ext.hpe.com

Drop Box Host: ftp.ext.hpe.com (15.241.164.77, Failover: 15.241.48.63)
Login: ffd55233
Password: G8dv.IV5 (NOTE: CASE-sensitive)
Account Expires: 06.04.2018 10:45:44 (drop box expiry/deletion date)

 

 

Regards

Marcin Weglarski

HPE Employee

Highlighted
Jimmy Vance
HPE Pro

Re: Ubuntu 16.04LTS on DL20Gen9


@vovanj7wrote:

Hi all!

I have strange behavior on my DL 20 Gen9 server with installed Ubuntu 16.04.3 LTS

I have disabled B140i and enabled AHCI Legacy mode and successfully install OS

When I try to edit the boot parameters( throught ILO), I can enter a small number of characters and after that the system freezes and does not react to clicking.

When I try edit grub parameters via text editor inside OS  (throught ILO) OS doesn't freeze

I updated all firmware to the latest version 

https://certification.ubuntu.com/hardware/201605-22006/

my CPU is intel Pentium G4400, 16Gb RAM, and 1 Tb HDD

Can somebody tells me why I can't  edit grub parameters?


Hopefully you've resolved the issue. Sounds like you may be having some type of network issue. Are you using the .net or java remote console?  Have you tried using the textcons functionality over an SSH session into the iLO?  For the later to work you need to make sure the console is just plain VGA and not using any graphics or frame buffers

Also curious as to why you are switching to legacy boot emulation. 16.04 should work just fine with UEFI

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
vovanj7
Occasional Visitor

Re: Ubuntu 16.04LTS on DL20Gen9

hi all,

I have resolved an issue just switch to UEFI from Legacy BIOS and update to the latest firmware from SPP.

But this behavior very stange for me: in Legacy mode it is freezing, in UEFI not...