ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Install Windows OS on ML150 G9

 
JW266
Occasional Advisor

Unable to Install Windows OS on ML150 G9

I recently got a ML150 G9 and am not able to install SBS2011.  I use IP with all defaults to install it and it was going well at the beginning of the installation until the progress bar almost reached to the end then "Windows installation cannot continue because a required driver coulbd not be installed" popped up. Finally everything was reinstated.  When the machine was rebooted after the installation failure, two other error messages "Firmeare Bug: the BIOS has corrupted hw-PMU resources (MSR 38d is 330)" and "Can't read CTR while initializing i8042" shown.  

Just wondering has anyone come across this situation and hoping someone can give me an idea to fix.  Thanks a lot.

 

12 REPLIES
Jimmy Vance
HPE Pro

Re: Unable to Install Windows OS on ML150 G9

So I'm not sure what is causing your OS installation issue. Have you tried just booting the OS media without using IP?  But I do want to state that the messages "Firmware Bug: the BIOS has corrupted hw-PMU resources (MSR 38d is 330)" and "Can't read CTR while initializing i8042" are being generated by the Linux kernel boot from IP. These two error messages are generated on all Proliant servers booting a Linux kernel.

In your case with the Windows installation failing, when rebooted I would assume that IP would attempt to restart if the Windows boot loader isn't installed.

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
JW266
Occasional Advisor

Re: Unable to Install Windows OS on ML150 G9

Thanks Jimmy.  Actually my attention was drawn to "corrupted" and was looking for updated firmware.   Do I have to turn off IP first for booting from the OS media?  I don;t see very clear instructions for doing that.

Jimmy Vance
HPE Pro

Re: Unable to Install Windows OS on ML150 G9

No, you do not need to turn IP off to boot from the OS media.  If your system is stuck in a weird state where IP keeps booting to attempt the installation, you can reset NVRAM to clear the IP boot setting. Check the label on the server lid panel for switch 6

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
JW266
Occasional Advisor

Re: Unable to Install Windows OS on ML150 G9

Thanks again.  Just wondering if it would be beacause SBS2011 is not one of the supported OS for ML150 G9.  I actually tried to install WS2012 last night and was almost able to get it installed except I was getting another error which was about to OS license key.  Somehow IP didn't take me to the 4th tab of Config and Install option (which seems to be where I can key in the key).  Anyway, I'll re-try SBS2011 as you suggested tonight.

Jimmy Vance
HPE Pro

Re: Unable to Install Windows OS on ML150 G9

I don't think SBS2011 is supported on any of the Gen9 servers. 

A couple of things to try:

Disable UEFI Optimized boot under RBSU System Options
Change from UEFI to Legacy BIOS mode

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
JW266
Occasional Advisor

Re: Unable to Install Windows OS on ML150 G9

I tried to boot from OS media.  I got the following message after clicking on Install:

"A required CD/DVD drive device driver is missing.  If you have a driver floppy disk, CD, DVD or USB flash drive, please insert it now."

I clicked Browse and only saw X drive.  So it sounds like OS media doesn't have a driver compatible for ML150 G9.  If this is correct, where can I find it?

Jimmy, your last post suggested me to disable UEFI Optimized boot and boot from legacy BIOS mode.  Do you think this can be the workaround?

Thanks.

 

Jimmy Vance
HPE Pro

Re: Unable to Install Windows OS on ML150 G9

The driver page for the ML150 Gen9 doesn't show list SBS2011, the OS support matrix dosn't list it either

http://h20566.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=7481832&lang=en&cc=us

 

http://h17007.www1.hp.com/us/en/enterprise/servers/supportmatrix/windows.aspx#.V5INqU32bDA

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
JW266
Occasional Advisor

Re: Unable to Install Windows OS on ML150 G9

Thanks.  Since SBS2011 is built on the foundation of WS2008 R2, just wondering if there's any driver from WS2008 R2 that will work or simply there is no way to install SBS2011 on ML150 G9.  (I am able to installl WS2008 R2 sucessfully).

JW266
Occasional Advisor

Re: Unable to Install Windows OS on ML150 G9

Hi everyone,

Is it impossible to install SBS2011 on ML150 G9?  Since SBS2011 is bulit on the foundation of WS2008R2 which is installable on ML150 G9, is there a way I can copy the drivers from WS2008 R2?  Thanks for any reply.

Jimmy Vance
HPE Pro

Re: Unable to Install Windows OS on ML150 G9

You can try installing the 2008 drivers.  I know I've used 2008 drivers with Win7 on the Microserver Gen8. Another option is to load hyper-v then load your OS as a VM




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
JW266
Occasional Advisor

Re: Unable to Install Windows OS on ML150 G9

Thanks again, Jimmy.  Where can I get WS2008 R2 drivers?  Do I install Ws2008 R2 first and find them from any of the folders?

Jimmy Vance
HPE Pro

Re: Unable to Install Windows OS on ML150 G9

Go to the HPSC site and enter your model number and drill down to drivers

http://h20566.www2.hpe.com/portal/site/hpsc

 

Already selected, just pick your OS

http://h20565.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=7481832&lang=en&cc=us




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!